summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-06-30 16:20:34 +0200
committerMartino Pilia2018-06-30 16:20:34 +0200
commitde9fdb71be774e831f3c54e82904990226ef3875 (patch)
tree9ab0d13d4458b42f3055ce313ac5400da68f640d
parent0f8d4a9720dacf786df1060d04c257609b93e1d6 (diff)
downloadaur-python-pyelastix.tar.gz
patch the code to not run Python subprocess through the shell
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27f05236a747..837eb2e7fc54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyelastix
pkgdesc = Python wrapper for the Elastix nonrigid registration toolkit
pkgver = 1.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/almarklein/pyelastix
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 287452ec9d01..607b37b3c357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=pyelastix
pkgname=python-$_pkgname
pkgver=1.1
-pkgrel=2
+pkgrel=3
pkgdesc="Python wrapper for the Elastix nonrigid registration toolkit"
arch=('x86_64')
url="https://github.com/almarklein/pyelastix"
@@ -14,6 +14,10 @@ sha512sums=('e3258111ece1ad67f9de8469200ee06a3d8db4d07b85a6ba0fa96c41ba6e3744531
package() {
cd "$srcdir/$_pkgname-$pkgver"
+
+ # do not run Python subprocess through the shell
+ sed -i '304s/True/False/' pyelastix.py
+
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --optimize=1 --root="$pkgdir"
}