summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-06-29 14:43:05 +0200
committerMartino Pilia2018-06-29 14:43:05 +0200
commit7021a88e279571dbfc74b3ff53ec292e8db91f2f (patch)
tree69ed671bb6a074c237e5f8ba44ac66e63a81e38f
downloadaur-7021a88e279571dbfc74b3ff53ec292e8db91f2f.tar.gz
package submission
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..396d700066ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pyelastix
+ pkgdesc = Python wrapper for the Elastix nonrigid registration toolkit
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://nipy.org/dipy/
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = elastix
+ source = https://github.com/almarklein/pyelastix/archive/v1.1.tar.gz
+ sha512sums = e3258111ece1ad67f9de8469200ee06a3d8db4d07b85a6ba0fa96c41ba6e37445313c5cce6bda6e96bb4e1fb0d6c60dc0a5d79e5e3ce76eb55f042550ad121da
+
+pkgname = python-pyelastix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f5e373399f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=pyelastix
+pkgname=python-$_pkgname
+pkgver=1.1
+pkgrel=1
+pkgdesc="Python wrapper for the Elastix nonrigid registration toolkit"
+arch=('x86_64')
+url="http://nipy.org/dipy/"
+license=('MIT')
+depends=('python-numpy' 'elastix')
+makedepends=('python-setuptools')
+source=("https://github.com/almarklein/pyelastix/archive/v${pkgver}.tar.gz")
+sha512sums=('e3258111ece1ad67f9de8469200ee06a3d8db4d07b85a6ba0fa96c41ba6e37445313c5cce6bda6e96bb4e1fb0d6c60dc0a5d79e5e3ce76eb55f042550ad121da')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root="$pkgdir"
+}