summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-04-02 17:53:51 +0200
committerM0Rf302019-04-02 17:53:51 +0200
commitd323212f63340513924b48b7c049c6924c7f12ad (patch)
treef4e46e335e65165bee51f127b60a6b2de8e898df
parentdede1338c980c708718ef6d2a4ea08854dc84d96 (diff)
downloadaur-d323212f63340513924b48b7c049c6924c7f12ad.tar.gz
python-pyelliptic: using radfish (redfish) fork: bump to 2.0.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f38d22091fc..05ec905e7a82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-pyelliptic
- pkgdesc = Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish...
- pkgver = 1.5.8
+ pkgdesc = Python OpenSSL wrapper for ECC (ECDSA, ECIES), AES, HMAC, Blowfish, ...
+ pkgver = 2.0.1
pkgrel = 1
- url = https://github.com/yann2192/pyelliptic
+ url = https://github.com/radfish/pyelliptic
arch = any
license = GPL3
makedepends = python-setuptools
depends = openssl
- source = https://github.com/yann2192/pyelliptic/archive/1.5.8.tar.gz
- sha256sums = ec23fb3a39a9ad9402354c2ac6c66990e737435365eb313070dd9a76e6849153
+ source = https://github.com/radfish/pyelliptic/archive/2.0.1.tar.gz
+ sha256sums = 840ad6f5e79c633e1de79fb08be78bf76fe07a7f260905eea31efb5ddf00180d
pkgname = python-pyelliptic
- provides = python-pyelliptic=1.5.8
+ provides = python-pyelliptic=2.0.1
diff --git a/PKGBUILD b/PKGBUILD
index 0e5cf128b708..353fa52c165e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,40 @@
# Maintainer: robertfoster
-# Contributor: redfish
pkgbase=python-pyelliptic
pkgname=(
-#'python2-pyelliptic'
+ #'python2-pyelliptic'
'python-pyelliptic')
_pkgname=pyelliptic
-pkgver=1.5.8
+pkgver=2.0.1
pkgrel=1
-pkgdesc="Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish..."
+pkgdesc="Python OpenSSL wrapper for ECC (ECDSA, ECIES), AES, HMAC, Blowfish, ..."
arch=(any)
-url="https://github.com/yann2192/pyelliptic"
+url="https://github.com/radfish/pyelliptic"
license=('GPL3')
depends=('openssl')
makedepends=('python-setuptools')
-source=(https://github.com/yann2192/pyelliptic/archive/$pkgver.tar.gz)
+source=(https://github.com/radfish/pyelliptic/archive/$pkgver.tar.gz)
build() {
- cp -a ${_pkgname}-${pkgver}{,-py2}
+ cp -a ${_pkgname}-${pkgver}{,-py2}
- cd ${_pkgname}-${pkgver}
- python setup.py build
+ cd ${_pkgname}-${pkgver}
+ python setup.py build
- cd ../${_pkgname}-${pkgver}-py2
- python2 setup.py build
+ cd ../${_pkgname}-${pkgver}-py2
+ python2 setup.py build
}
package_python-pyelliptic(){
- provides=("$pkgname=$pkgver")
- cd ${_pkgname}-${pkgver}
- python setup.py install --root="$pkgdir" --skip-build
+ provides=("$pkgname=$pkgver")
+ cd ${_pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --skip-build
}
package_python2-pyelliptic(){
- provides=("$pkgname=$pkgver")
- cd ${_pkgname}-${pkgver}-py2
- python2 setup.py install --root="$pkgdir" --skip-build
+ provides=("$pkgname=$pkgver")
+ cd ${_pkgname}-${pkgver}-py2
+ python2 setup.py install --root="$pkgdir" --skip-build
}
-sha256sums=('ec23fb3a39a9ad9402354c2ac6c66990e737435365eb313070dd9a76e6849153')
+sha256sums=('840ad6f5e79c633e1de79fb08be78bf76fe07a7f260905eea31efb5ddf00180d')