summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-20 21:27:39 -0500
committerclintval2017-12-20 21:27:39 -0500
commit5b8631055ea7c18a356ad5402d87de28f5d12c01 (patch)
treedb7852cd26a310a2a15a31658b884915ceab6c5a
downloadaur-5b8631055ea7c18a356ad5402d87de28f5d12c01.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa9d4c507f67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-pyentrezid
+ pkgdesc = Converts Ensembl, Uniprot, and HGNC IDs to Entrez Gene Id
+ pkgver = 1.4.9
+ pkgrel = 1
+ url = https://github.com/lwgray/pyEntrezId
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-colorama>=0.3.7
+ depends = python-nose>=1.3.7
+ depends = python-pygments>=2.1.3
+ depends = python-rednose>=1.1.1
+ depends = python-termstyle>=0.1.10
+ depends = python-requests>=2.10.0
+ depends = python-xmltodict>=0.10.1
+ conflicts = python-pyentrezid
+ options = !emptydirs
+ source = git+https://github.com/lwgray/pyEntrezId.git
+ md5sums = SKIP
+
+pkgname = python-pyentrezid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62cbcff1b991
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-pyentrezid'
+pkgver=1.4.9
+pkgrel=1
+pkgdesc="Converts Ensembl, Uniprot, and HGNC IDs to Entrez Gene Id"
+arch=('any')
+url="https://github.com/lwgray/pyEntrezId"
+license=('MIT')
+depends=(
+ 'python'
+ 'python-colorama>=0.3.7'
+ 'python-nose>=1.3.7'
+ 'python-pygments>=2.1.3'
+ 'python-rednose>=1.1.1'
+ 'python-termstyle>=0.1.10'
+ 'python-requests>=2.10.0'
+ 'python-xmltodict>=0.10.1'
+)
+makedepends=('python-setuptools')
+rovides=('python-pyentrezid')
+conflicts=('python-pyentrezid')
+options=(!emptydirs)
+source=("git+https://github.com/lwgray/pyEntrezId.git")
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}/pyEntrezId"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}