summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-21 18:08:45 -0800
committerclintval2018-01-21 18:08:45 -0800
commitd874a48ca643befeba4e74341b073a39e4110c9b (patch)
treef0a379d55b77ddbf9c9e6514356d787ab7c2fe11
parentb8bad28b2f671b02a20cec78b485f94663161f10 (diff)
downloadaur-d874a48ca643befeba4e74341b073a39e4110c9b.tar.gz
python-pyentrezid to 1.5.8.2 and split package
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD78
2 files changed, 85 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ea91b7c33f1..859def60ebc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,37 @@
pkgbase = python-pyentrezid
pkgdesc = Converts Ensembl, Uniprot, and HGNC IDs to Entrez Gene Id
- pkgver = 1.4.9
+ pkgver = 1.5.8.2
pkgrel = 1
- url = https://github.com/lwgray/pyEntrezId
+ url = https://pypi.python.org/pypi/PyEntrezId
arch = any
license = MIT
+ makedepends = python
makedepends = python-setuptools
- depends = python
- depends = python-colorama>=0.3.7
- depends = python-nose>=1.3.7
- depends = python-pygments>=2.1.3
- depends = python-rednose>=1.1.1
- depends = python-termstyle>=0.1.10
- depends = python-requests>=2.10.0
- depends = python-xmltodict>=0.10.1
- conflicts = python-pyentrezid
+ makedepends = python2
+ makedepends = python2-setuptools
options = !emptydirs
- source = https://github.com/lwgray/pyEntrezId/archive/1.4.9.tar.gz
- md5sums = b740cfc50a6ed8b50468557f6872c047
+ source = https://raw.githubusercontent.com/lwgray/pyEntrezId/28286cf21b876dd4894bf21a222dfd1022441b75/LICENSE
+ source = python-pyentrezid-1.5.8.2.tar.gz::https://pypi.python.org/packages/3f/23/14d4062c213506b25e453d2a858a3ce7564e821b1ae0d3f9b1619d739594/PyEntrezId-1.5.8.2.tar.gz
+ sha256sums = 21366ef752c0c7fbf91c46ff163212d3991c6f31cf5edd216467966c50783e7e
+ sha256sums = eb413e67109c1609464fda325fd1b6703bdfacff93e83cfd02e9ba2b937c230f
pkgname = python-pyentrezid
+ depends = python
+ depends = python-colorama
+ depends = python-nose
+ depends = python-pygments
+ depends = python-rednose
+ depends = python-termstyle
+ depends = python-requests
+ depends = python-xmltodict
+
+pkgname = python2-pyentrezid
+ depends = python2
+ depends = python2-colorama
+ depends = python2-nose
+ depends = python2-pygments
+ depends = python2-rednose
+ depends = python2-termstyle
+ depends = python2-requests
+ depends = python2-xmltodict
diff --git a/PKGBUILD b/PKGBUILD
index 8f0e0f16cadc..aa5bcbcab345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,67 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-pkgname='python-pyentrezid'
-pkgver=1.4.9
+_name=PyEntrezId
+pkgbase='python-pyentrezid'
+pkgname=('python-pyentrezid' 'python2-pyentrezid')
+pkgver=1.5.8.2
pkgrel=1
pkgdesc="Converts Ensembl, Uniprot, and HGNC IDs to Entrez Gene Id"
arch=('any')
-url="https://github.com/lwgray/pyEntrezId"
+url=https://pypi.python.org/pypi/"${_name}"
license=('MIT')
-depends=(
- 'python'
- 'python-colorama>=0.3.7'
- 'python-nose>=1.3.7'
- 'python-pygments>=2.1.3'
- 'python-rednose>=1.1.1'
- 'python-termstyle>=0.1.10'
- 'python-requests>=2.10.0'
- 'python-xmltodict>=0.10.1')
-makedepends=('python-setuptools')
-rovides=('python-pyentrezid')
-conflicts=('python-pyentrezid')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
options=(!emptydirs)
-source=("https://github.com/lwgray/pyEntrezId/archive/${pkgver}.tar.gz")
-md5sums=('b740cfc50a6ed8b50468557f6872c047')
+source=(
+ https://raw.githubusercontent.com/lwgray/pyEntrezId/28286cf21b876dd4894bf21a222dfd1022441b75/LICENSE
+ "${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/3f/23/14d4062c213506b25e453d2a858a3ce7564e821b1ae0d3f9b1619d739594/PyEntrezId-1.5.8.2.tar.gz
+)
+sha256sums=(
+ '21366ef752c0c7fbf91c46ff163212d3991c6f31cf5edd216467966c50783e7e'
+ 'eb413e67109c1609464fda325fd1b6703bdfacff93e83cfd02e9ba2b937c230f'
+)
-package() {
- cd "${srcdir}/pyEntrezId-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-pyentrezid() {
+ depends=(
+ 'python2'
+ 'python2-colorama'
+ 'python2-nose'
+ 'python2-pygments'
+ 'python2-rednose'
+ 'python2-termstyle'
+ 'python2-requests'
+ 'python2-xmltodict')
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}
+
+package_python-pyentrezid() {
+ depends=(
+ 'python'
+ 'python-colorama'
+ 'python-nose'
+ 'python-pygments'
+ 'python-rednose'
+ 'python-termstyle'
+ 'python-requests'
+ 'python-xmltodict')
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
}