summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2023-06-21 21:28:23 +0200
committerBlair Bonnett2023-06-21 21:28:23 +0200
commit2b66400a17c2bac4e42e2f7ab2a8fd58d36f168a (patch)
tree8f06a0612a059dbbcd198b190111ed1c9bf3e51f
parentd7ee0569cdb92a82bbabc3ee6a5350dcdf0dd76f (diff)
downloadaur-2b66400a17c2bac4e42e2f7ab2a8fd58d36f168a.tar.gz
Switch to PEP517 build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01b16f60de95..87cacf7437e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-pyepsg
pkgdesc = A simple interface to https://epsg.io/
pkgver = 0.4.0
- pkgrel = 1
- url = https://github.com/rhattersley/pyepsg
+ pkgrel = 2
+ url = https://pyepsg.readthedocs.io/
arch = any
license = LGPL3
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-requests
source = https://files.pythonhosted.org/packages/source/p/pyepsg/pyepsg-0.4.0.tar.gz
sha256sums = 2d08fad1e7a8b47a90a4e43da485ba95705923425aefc4e2a3efa540dbd470d7
pkgname = python-pyepsg
-
diff --git a/PKGBUILD b/PKGBUILD
index 108038a2a131..334ed4dcd4cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,29 @@
pkgname=python-pyepsg
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='A simple interface to https://epsg.io/'
-url='https://github.com/rhattersley/pyepsg'
+url='https://pyepsg.readthedocs.io/'
arch=('any')
license=('LGPL3')
+
depends=('python-requests')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+_pypi=pyepsg
source=(
- "https://files.pythonhosted.org/packages/source/p/pyepsg/pyepsg-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
'2d08fad1e7a8b47a90a4e43da485ba95705923425aefc4e2a3efa540dbd470d7'
)
build() {
- cd "pyepsg-$pkgver"
- python setup.py build
+ cd "$_pypi-$pkgver"
+ python -m build --no-isolation --wheel
}
package() {
- cd "pyepsg-$pkgver"
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ cd "$_pypi-$pkgver"
+ python -m installer --destdir="$pkgdir" "dist/$_pypi-$pkgver-"*.whl
}