summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2020-09-19 18:28:00 +0200
committerBlair Bonnett2020-09-19 18:28:00 +0200
commitd7ee0569cdb92a82bbabc3ee6a5350dcdf0dd76f (patch)
treee47d477dbb5948fdc0fe61a27ccfc15ffdf19c4b
downloadaur-d7ee0569cdb92a82bbabc3ee6a5350dcdf0dd76f.tar.gz
Initial package of version 0.4.0.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01b16f60de95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyepsg
+ pkgdesc = A simple interface to https://epsg.io/
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/rhattersley/pyepsg
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/p/pyepsg/pyepsg-0.4.0.tar.gz
+ sha256sums = 2d08fad1e7a8b47a90a4e43da485ba95705923425aefc4e2a3efa540dbd470d7
+
+pkgname = python-pyepsg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ce0c44eaf5c1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src
+pkg
+*.pkg.tar.xz
+*.pkg.tar.zst
+*.tar.gz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..108038a2a131
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
+
+pkgname=python-pyepsg
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='A simple interface to https://epsg.io/'
+url='https://github.com/rhattersley/pyepsg'
+arch=('any')
+license=('LGPL3')
+depends=('python-requests')
+makedepends=('python-setuptools')
+
+source=(
+ "https://files.pythonhosted.org/packages/source/p/pyepsg/pyepsg-$pkgver.tar.gz"
+)
+sha256sums=(
+ '2d08fad1e7a8b47a90a4e43da485ba95705923425aefc4e2a3efa540dbd470d7'
+)
+
+build() {
+ cd "pyepsg-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "pyepsg-$pkgver"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+}