summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos José Ruiz-Henestrosa Ruiz2020-07-21 17:39:53 +0200
committerCarlos José Ruiz-Henestrosa Ruiz2020-07-21 17:39:53 +0200
commit8b0d6b60af8db34f7d032e56dd94d55771ca92c8 (patch)
tree7930583c7a826cfcf33fcab7533c3378ab890c68
downloadaur-8b0d6b60af8db34f7d032e56dd94d55771ca92c8.tar.gz
First version, based on python-pyexcel-xlsx
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4c272cf5945
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pyexcel-xls
+ pkgdesc = A wrapper library to read, manipulate and write data in xls, and read xlsx and xlsm format using pyexcel
+ pkgver = 0.5.8
+ pkgrel = 1
+ url = https://github.com/pyexcel/pyexcel-xls
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python>=3.3
+ depends = python-pyexcel-io>=0.5.3
+ depends = python-xlrd
+ depends = python-xlwt
+ source = https://github.com/pyexcel/pyexcel-xls/archive/v0.5.8.tar.gz
+ sha256sums = 1d0d2094b0f5954889ff30acada8cc4c966b1c8eff4049c0b10c59779fc861eb
+
+pkgname = python-pyexcel-xls
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f34a96c51ab9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17df6a373c15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Carlos José Ruiz-Henestrosa Ruiz <ruizh.cj@gmail.com>
+_pkgname=pyexcel-xls
+pkgname=python-$_pkgname
+pkgver=0.5.8
+pkgrel=1
+pkgdesc='A wrapper library to read, manipulate and write data in xls, and read xlsx and xlsm format using pyexcel'
+url="https://github.com/pyexcel/$_pkgname"
+arch=('any')
+license=('BSD')
+depends=('python>=3.3'
+ 'python-pyexcel-io>=0.5.3'
+ 'python-xlrd'
+ 'python-xlwt')
+makedepends=('python-setuptools')
+source=("${_pkgname}-${pkgver}"::"$url/archive/v$pkgver.tar.gz")
+sha256sums=('1d0d2094b0f5954889ff30acada8cc4c966b1c8eff4049c0b10c59779fc861eb')
+
+build(){
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: