summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2016-05-09 12:25:19 +0200
committerGilrain2016-05-09 12:25:19 +0200
commita3b6af358551a477e1aee309ebb23229a0b367d1 (patch)
tree3734aecb2c4a70c81d449797835f2394d1be9926
parente340e49dcf633d51cbf93e4d30e5c684c3a98025 (diff)
downloadaur-a3b6af358551a477e1aee309ebb23229a0b367d1.tar.gz
Update to 1.4.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--changelog32
3 files changed, 56 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb95ba4b6401..48282055c08e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
# Generated by mksrcinfo v8
-# Tue Apr 5 18:38:39 UTC 2016
+# Mon May 9 10:24:53 UTC 2016
pkgbase = python-pyexecjs
pkgdesc = Run JavaScript code from Python.
- pkgver = 1.3.1
+ pkgver = 1.4.0
pkgrel = 1
url = https://pypi.python.org/pypi/PyExecJS
+ changelog = changelog
arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://pypi.python.org/packages/source/P/PyExecJS/PyExecJS-1.3.1.tar.gz
- md5sums = cb64d118cc48af724088f35a2e9955aa
+ makedepends = python-packaging
+ makedepends = python2-packaging
+ makedepends = git
+ source = git+https://github.com/doloopwhile/PyExecJS.git#tag=v1.4.0
+ sha512sums = SKIP
pkgname = python-pyexecjs
- depends = python
depends = python-six
pkgname = python2-pyexecjs
- depends = python2
depends = python2-six
diff --git a/PKGBUILD b/PKGBUILD
index 5c447677837f..b0ab660988d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,49 +2,49 @@
pkgbase=python-pyexecjs
pkgname=('python-pyexecjs' 'python2-pyexecjs')
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc="Run JavaScript code from Python."
arch=('any')
url="https://pypi.python.org/pypi/PyExecJS"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=(https://pypi.python.org/packages/source/P/PyExecJS/PyExecJS-${pkgver}.tar.gz)
-md5sums=('cb64d118cc48af724088f35a2e9955aa')
+makedepends=('python-packaging' 'python2-packaging' 'git')
+changelog=changelog
+source=(git+https://github.com/doloopwhile/PyExecJS.git#tag=v$pkgver)
+sha512sums=('SKIP')
prepare() {
- cp -r PyExecJS-$pkgver PyExecJS-$pkgver-python
- cp -r PyExecJS-$pkgver PyExecJS-$pkgver-python2
+ cp -a PyExecJS{,-python2}
}
build() {
- cd "PyExecJS-$pkgver-python"
+ cd "PyExecJS"
python setup.py build
- cd "../PyExecJS-$pkgver-python2"
+ cd "../PyExecJS-python2"
python2 setup.py build
}
check() {
- cd "PyExecJS-$pkgver-python"
+ cd "PyExecJS"
LC_CTYPE=en_US.utf8 python test_execjs.py || warning "Tests failed"
- cd "../PyExecJS-$pkgver-python2"
+ cd "../PyExecJS-python2"
LC_CTYPE=en_US.utf8 python2 test_execjs.py || warning "Tests failed"
}
package_python-pyexecjs() {
- depends=('python' 'python-six')
+ depends=('python-six')
- cd "PyExecJS-$pkgver-python"
- python setup.py install --root="$pkgdir" -O1
+ cd "PyExecJS"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
package_python2-pyexecjs() {
- depends=('python2' 'python2-six')
+ depends=('python2-six')
- cd "PyExecJS-$pkgver-python2"
- python2 setup.py install --root="$pkgdir" -O1
+ cd "PyExecJS-python2"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..ee67b02c5037
--- /dev/null
+++ b/changelog
@@ -0,0 +1,32 @@
+2016-05-09 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 1.4.0:
+ Fixed required libraries.
+ Fixed order of output of --print-available-runtimes.
+ Execute some JavaScript runtime with pipe/stdin (without temporary file).
+ * 1.3.1:
+ Fixed --print-available-runtimes fails in Python 2.7.
+ * 1.3.0:
+ Added cwd argument.
+ * 1.2.0:
+ Supported Python 3.5
+ Supported Nashorn(Java 8 JavaScript engine) as runtime
+ Dropped support for Python 2.6 and 3.2
+ * 1.1.0:
+ Supported Python 3.4
+ Supported SlimerJS as runtime
+ Supported PhantomJS as runtime
+ Fixed JScript runtime on Windows 8
+ * 1.0.5:
+ Supported Python 3.3
+ Fixed file handle leaking
+ Fixed issue with passenger-nginx-4.0
+ * 1.0.4:
+ Removed “import execjs” (it prevent execution of setup.py by Python 2.6)
+ * 1.0.3:
+ Javascript sources were embeded in init.py. ‘which’ command were reimplemented by pure python.
+ * 1.0.2:
+ Python 2.6.x was supported.
+ * 1.0.1:
+ Forgotten shell=True was added to Popen.
+ * 1.0.0:
+ First release.