summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2016-09-25 11:01:02 +0200
committerGilrain2016-09-25 11:01:02 +0200
commitc43fce5a78c6a6b205486d5f5f08656f0d120ce0 (patch)
tree29b08be5dc65f2a47b44c3181a9e6eaa9eac725e
parent532215dc1094b535d1079c3651d37411340eab90 (diff)
downloadaur-c43fce5a78c6a6b205486d5f5f08656f0d120ce0.tar.gz
pkg: use github release tarball
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74a9fb08cbec..8b99068553ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Sep 25 08:46:30 UTC 2016
+# Sun Sep 25 09:00:36 UTC 2016
pkgbase = python-pyexecjs
pkgdesc = Run JavaScript code from Python.
pkgver = 1.4.0
@@ -11,8 +11,8 @@ pkgbase = python-pyexecjs
makedepends = python-setuptools
makedepends = python2-setuptools
makedepends = git
- source = git+https://github.com/doloopwhile/PyExecJS.git#tag=v1.4.0
- sha512sums = SKIP
+ source = https://github.com/doloopwhile/PyExecJS/archive/v1.4.0.tar.gz
+ sha256sums = 5727169af658c0405bd4446b42bdf659d7c96158dfe8cfebc390dd33284eec75
pkgname = python-pyexecjs
depends = python-six
diff --git a/PKGBUILD b/PKGBUILD
index acbee184a638..5ce1564b29f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,33 +10,33 @@ url="https://pypi.python.org/pypi/PyExecJS"
license=('MIT')
makedepends=('python-setuptools' 'python2-setuptools' 'git')
changelog=changelog
-source=(git+https://github.com/doloopwhile/PyExecJS.git#tag=v$pkgver)
-sha512sums=('SKIP')
+source=(https://github.com/doloopwhile/PyExecJS/archive/v$pkgver.tar.gz)
+sha256sums=('5727169af658c0405bd4446b42bdf659d7c96158dfe8cfebc390dd33284eec75')
prepare() {
- cp -a PyExecJS{,-python2}
+ cp -a PyExecJS-$pkgver{,-python2}
}
build() {
- cd "PyExecJS"
+ cd "PyExecJS-$pkgver"
python setup.py build
- cd "../PyExecJS-python2"
+ cd "../PyExecJS-$pkgver-python2"
python2 setup.py build
}
check() {
- cd "PyExecJS"
+ cd "PyExecJS-$pkgver"
LC_CTYPE=en_US.utf8 python test_execjs.py || warning "Tests failed"
- cd "../PyExecJS-python2"
+ cd "../PyExecJS-$pkgver-python2"
LC_CTYPE=en_US.utf8 python2 test_execjs.py || warning "Tests failed"
}
package_python-pyexecjs() {
depends=('python-six')
- cd "PyExecJS"
+ cd "PyExecJS-$pkgver"
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
@@ -44,7 +44,7 @@ package_python-pyexecjs() {
package_python2-pyexecjs() {
depends=('python2-six')
- cd "PyExecJS-python2"
+ cd "PyExecJS-$pkgver-python2"
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}