summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2016-04-05 20:39:14 +0200
committerGilrain2016-04-05 20:39:14 +0200
commite340e49dcf633d51cbf93e4d30e5c684c3a98025 (patch)
treefc12db7e6c8023cc97dc9d367c1c02de9e583ad8
downloadaur-e340e49dcf633d51cbf93e4d30e5c684c3a98025.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD50
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb95ba4b6401
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Apr 5 18:38:39 UTC 2016
+pkgbase = python-pyexecjs
+ pkgdesc = Run JavaScript code from Python.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/PyExecJS
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/P/PyExecJS/PyExecJS-1.3.1.tar.gz
+ md5sums = cb64d118cc48af724088f35a2e9955aa
+
+pkgname = python-pyexecjs
+ depends = python
+ depends = python-six
+
+pkgname = python2-pyexecjs
+ depends = python2
+ depends = python2-six
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c447677837f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+
+pkgbase=python-pyexecjs
+pkgname=('python-pyexecjs' 'python2-pyexecjs')
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Run JavaScript code from Python."
+arch=('any')
+url="https://pypi.python.org/pypi/PyExecJS"
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=(https://pypi.python.org/packages/source/P/PyExecJS/PyExecJS-${pkgver}.tar.gz)
+md5sums=('cb64d118cc48af724088f35a2e9955aa')
+
+prepare() {
+ cp -r PyExecJS-$pkgver PyExecJS-$pkgver-python
+ cp -r PyExecJS-$pkgver PyExecJS-$pkgver-python2
+}
+
+build() {
+ cd "PyExecJS-$pkgver-python"
+ python setup.py build
+
+ cd "../PyExecJS-$pkgver-python2"
+ python2 setup.py build
+}
+
+check() {
+ cd "PyExecJS-$pkgver-python"
+ LC_CTYPE=en_US.utf8 python test_execjs.py || warning "Tests failed"
+
+ cd "../PyExecJS-$pkgver-python2"
+ LC_CTYPE=en_US.utf8 python2 test_execjs.py || warning "Tests failed"
+}
+
+package_python-pyexecjs() {
+ depends=('python' 'python-six')
+
+ cd "PyExecJS-$pkgver-python"
+ python setup.py install --root="$pkgdir" -O1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-pyexecjs() {
+ depends=('python2' 'python2-six')
+
+ cd "PyExecJS-$pkgver-python2"
+ python2 setup.py install --root="$pkgdir" -O1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}