summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonid Bloch2024-02-17 18:21:10 +0200
committerLeonid Bloch2024-02-17 18:21:10 +0200
commite90bbacc4930fc13576e7b0df8230a08ef987be2 (patch)
treeb0529af53ab4b363055e5b2e6736816fbedd28da
parentca36976349ab645aaefe787a23716a4f43e2bb66 (diff)
downloadaur-python-pyfai.tar.gz
Bump version
Signed-off-by: Leonid Bloch <lb.workbox@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52860cb7cd7c..41eaa17772e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyfai
pkgdesc = Fast Azimuthal Integration in Python.
- pkgver = 2023.09
- pkgrel = 2
+ pkgver = 2024.02
+ pkgrel = 1
url = http://www.silx.org
arch = any
license = GPLv3
@@ -22,7 +22,7 @@ pkgbase = python-pyfai
depends = fftw
depends = opencl-driver
optdepends = python-silx: for additional functionality, like pyFAI-calib2
- source = https://github.com/silx-kit/pyFAI/archive/v2023.09.tar.gz
- sha256sums = d6cdd92a165d2b2c098095a1ddf7424cd77aeb52a1c36e730c2bf792d8d65fec
+ source = https://github.com/silx-kit/pyFAI/archive/v2024.02.tar.gz
+ sha256sums = 249b23007f28d0d93514b706f11c9721884375621749a037b158ca8ea40acb02
pkgname = python-pyfai
diff --git a/PKGBUILD b/PKGBUILD
index db8064f28254..0c684624f3d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Package maintainer: Leonid B <leonid dot bloch at esrf dot fr>
# Upstream contact: silx at esrf dot fr
pkgname=python-pyfai
-pkgver=2023.09
-pkgrel=2
+pkgver=2024.02
+pkgrel=1
pkgdesc="Fast Azimuthal Integration in Python."
arch=('any')
url="http://www.silx.org"
@@ -14,7 +14,7 @@ optdepends=('python-silx: for additional functionality, like pyFAI-calib2')
makedepends=('cython' 'meson-python' 'python-build' 'python-installer'
'python-wheel')
source=("https://github.com/silx-kit/pyFAI/archive/v${pkgver}.tar.gz")
-sha256sums=('d6cdd92a165d2b2c098095a1ddf7424cd77aeb52a1c36e730c2bf792d8d65fec')
+sha256sums=('249b23007f28d0d93514b706f11c9721884375621749a037b158ca8ea40acb02')
build() {
cd "pyFAI-${pkgver}"
@@ -22,6 +22,8 @@ build() {
# Remove ninja dependency, as it is brought with meson, and python-ninja
# is not in the official repos
sed -i "/^requires =/,/^\]/{/^[[:space:]]*'ninja',[[:space:]]*$/d}" pyproject.toml
+ # Remove non-existing package name from requirements
+ sed -i "/^requires =/,/^\]/{/^[[:space:]]*'oldest-supported-numpy',[[:space:]]*$/d}" pyproject.toml
python -m build --wheel --no-isolation
}