summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonid Bloch2017-01-04 00:04:40 +0200
committerLeonid Bloch2017-01-04 00:04:40 +0200
commitd764f53e0ab50051c6dc23afd2fa2ce3f9e3cf44 (patch)
treee5328075b8c3eb8019c6806defb66eda6f6acfd4
downloadaur-d764f53e0ab50051c6dc23afd2fa2ce3f9e3cf44.tar.gz
Initial commit
Signed-off-by: Leonid Bloch <leonid.bloch@esrf.fr>
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD26
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0413b053aa2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-pyfai
+ pkgdesc = Fast Azimuthal Integration in Python.
+ pkgver = 0.13.0
+ pkgrel = 1
+ url = http://www.silx.org
+ arch = any
+ license = GPLv3
+ license = BSD
+ license = MIT
+ makedepends = git
+ makedepends = cython
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
+ depends = python-fabio
+ depends = python-h5py
+ depends = python-pyopencl
+ depends = python-pyqt5
+ depends = fftw
+ depends = opencl-driver
+ source = https://github.com/silx-kit/pyFAI/archive/v0.13.0.tar.gz
+ sha1sums = 221f18a4048b5a6725f577ecde99656057e3f310
+
+pkgname = python-pyfai
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64d7bdeaec1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Package maintainer: Leonid B <leonid dot bloch at esrf dot fr>
+# Upstream contact: silx at esrf dot fr
+pkgname=python-pyfai
+pkgver=0.13.0
+pkgrel=1
+pkgdesc="Fast Azimuthal Integration in Python."
+arch=('any')
+url="http://www.silx.org"
+license=('GPLv3' 'BSD' 'MIT')
+depends=('python-numpy' 'python-scipy' 'python-matplotlib' 'python-fabio'
+ 'python-h5py' 'python-pyopencl' 'python-pyqt5' 'fftw' 'opencl-driver')
+makedepends=('git' 'cython')
+source=("https://github.com/silx-kit/pyFAI/archive/v${pkgver}.tar.gz")
+sha1sums=('221f18a4048b5a6725f577ecde99656057e3f310')
+
+build() {
+ cd "${srcdir}/pyFAI-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/pyFAI-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -D LICENSES.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D copyright "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+}