summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetscoin2018-07-24 07:43:59 -0400
committermetscoin2018-07-24 07:43:59 -0400
commit628997f43aaa4f96475fe50cfb3c902897ee1198 (patch)
tree963a727bf29bb9a82de9c22c6c724e65ac80675d
downloadaur-628997f43aaa4f96475fe50cfb3c902897ee1198.tar.gz
Init PyFastoGT repo
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD24
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..389f68fd4e67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-pyfastogt
+ pkgdesc = FastoGT python files
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://fastonosql.com
+ arch = any
+ license = MIT
+ source = python-pyfastogt::git+https://github.com/fastogt/pyfastogt.git
+ sha256sums = SKIP
+
+pkgname = python-pyfastogt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa1d44e79d66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=python-pyfastogt
+pkgver=0.0.1
+pkgrel=1
+arch=('any')
+url="https://fastonosql.com"
+license=('MIT')
+pkgdesc="FastoGT python files"
+depends=()
+makedepends=()
+conflicts=()
+source=("${pkgname%-git}::git+https://github.com/fastogt/pyfastogt.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$pkgname"
+ python "setup.py" build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python "setup.py" install --root="$pkgdir/" --optimize=1 --skip-build
+}