summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2019-06-09 21:06:53 -0300
committerRafael Fontenelle2019-06-09 21:06:53 -0300
commit5487b0ad12557a02963634382373dbf0158c9cdd (patch)
tree63e29c20decec3cc60518e72e84e9ac972722631
downloadaur-5487b0ad12557a02963634382373dbf0158c9cdd.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore20
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD27
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c0e92d7be6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pyfavicon
+ pkgdesc = Async favicon fetcher
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://pypi.org/pypi/pyfavicon
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-aiohttp
+ depends = python-pillow
+ depends = python-beautifulsoup4
+ source = https://pypi.org/packages/source/p/pyfavicon/pyfavicon-0.1.1.tar.gz
+ source = LICENSE
+ sha256sums = fdd5a222f08488824877d8a00a272657c4e66bbe115520d1d68e6d9892ba8e97
+ sha256sums = a689f5eb9e5b1e7d691031376a8be4961e551ee2173e5f1dc65b335d20469197
+
+pkgname = python-pyfavicon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aace9926737
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..fe834e77d18b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Bilal Elmoussaoui
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83d1ba304144
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+
+_name=pyfavicon
+pkgname=python-$_name
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Async favicon fetcher"
+arch=(any)
+url="https://pypi.org/pypi/$_name"
+license=('MIT')
+depends=('python-aiohttp' 'python-pillow' 'python-beautifulsoup4')
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+ 'LICENSE')
+sha256sums=('fdd5a222f08488824877d8a00a272657c4e66bbe115520d1d68e6d9892ba8e97'
+ 'a689f5eb9e5b1e7d691031376a8be4961e551ee2173e5f1dc65b335d20469197')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dvm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}