summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-05-11 13:43:26 -0500
committerCarlos Aznarán2024-05-11 13:43:26 -0500
commit967a98b45eadb77038b222bc0ee7a94f3bbbb456 (patch)
tree15770d4aee7aea176e03dc0e990de1cc9bffdeb7
parentb5cc21a92eb71cd4b2ee138f3b3da8970c731f36 (diff)
downloadaur-967a98b45eadb77038b222bc0ee7a94f3bbbb456.tar.gz
Disable some warnings
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c48106930b0a..2942ae065148 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyfftw
pkgdesc = A pythonic wrapper around FFTW
pkgver = 0.13.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/pyFFTW/pyFFTW
arch = i686
arch = x86_64
@@ -16,6 +16,7 @@ pkgbase = python-pyfftw
makedepends = cython
depends = fftw
depends = python-numpy
+ depends = openmp
optdepends = python-scipy: scipy.fftpack support
optdepends = python-dask: dask.fft support
source = pyFFTW-0.13.1.tar.gz::https://github.com/pyFFTW/pyFFTW/archive/v0.13.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index f8a2c2186bb6..e38e639596f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
_base=pyFFTW
pkgname=python-${_base,,}
pkgver=0.13.1
-pkgrel=4
+pkgrel=5
pkgdesc="A pythonic wrapper around FFTW"
arch=(i686 x86_64)
url="https://github.com/${_base}/${_base}"
license=(BSD-3-Clause)
-depends=(fftw python-numpy)
+depends=(fftw python-numpy openmp)
makedepends=(python-build python-installer python-setuptools python-wheel cython)
checkdepends=(python-pytest python-scipy python-dask)
optdepends=('python-scipy: scipy.fftpack support'
- 'python-dask: dask.fft support') # openmp
+ 'python-dask: dask.fft support')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz
cython3.patch::${url}/pull/363.patch
python312.patch::${url}/pull/370.patch)
@@ -30,6 +30,8 @@ prepare() {
build() {
cd ${_base}-${pkgver}
+ CFLAGS="-Wno-implicit-function-declaration -Wno-incompatible-pointer-types"
+ PYFFTW_USE_PTHREADS=1
python setup.py \
build_ext \
--include-dirs=/usr/include \