summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-05-26 02:27:14 +0800
committerYen Chi Hsuan2015-05-26 02:27:14 +0800
commit08ce0bc2306346d33919b19ed9a90ab31ab03eb3 (patch)
tree00291509e9833960743619173ebdacaaa9c45318
downloadaur-08ce0bc2306346d33919b19ed9a90ab31ab03eb3.tar.gz
Add python-pyflakes-git
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD74
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9ea19de5120
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-pyflakes-git
+ pkgdesc = A lint-like tool for Python to identify common errors quickly without executing code (Git version)
+ pkgver = 0.8.1.r35.g03ffc76
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pyflakes
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = pyflakes::git+https://github.com/pyflakes/pyflakes/
+ sha1sums = SKIP
+
+pkgname = python-pyflakes-git
+ depends = python-setuptools
+ provides = python-pyflakes
+ conflicts = python-pyflakes
+
+pkgname = python2-pyflakes-git
+ depends = python2-setuptools
+ provides = python2-pyflakes
+ conflicts = python2-pyflakes
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..53f726189e87
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/pyflakes
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc66cf1a686f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# $Id$
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Karol 'Kenji Takahashi' Woźniak <kenji.sx>
+# Contributor: Tianjiao Yin <ytj000+AUR@gmail.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: TDY <tdy@gmx.com>
+# Contributor: Tiago Pierezan Camargo <tcamargo@gmail.com>
+
+pkgbase=python-pyflakes-git
+pkgname=(python-pyflakes-git python2-pyflakes-git)
+_reponame=pyflakes
+pkgver=0.8.1.r35.g03ffc76
+pkgrel=1
+pkgdesc='A lint-like tool for Python to identify common errors quickly without executing code (Git version)'
+arch=('any')
+url='http://pypi.python.org/pypi/pyflakes'
+license=('MIT')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("${_reponame}"::"git+https://github.com/pyflakes/pyflakes/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_reponame"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cp -r "$srcdir/${_reponame}"{,-py2}
+}
+
+build() {
+ cd "$srcdir/${_reponame}"
+ python setup.py build
+
+ cd "$srcdir/${_reponame}-py2"
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir/${_reponame}"
+ python setup.py test
+
+ cd "$srcdir/${_reponame}-py2"
+ python2 setup.py test
+}
+
+package_python-pyflakes-git() {
+ depends=('python-setuptools')
+ provides=(python-pyflakes)
+ conflicts=(python-pyflakes)
+
+ cd "${_reponame}"
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+
+ # We have python 3 as default python, and want to keep compatibility with the old pyflakes3k naming
+ ln -s pyflakes "${pkgdir}/usr/bin/pyflakes3k"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pyflakes-git() {
+ depends=('python2-setuptools')
+ provides=(python2-pyflakes)
+ conflicts=(python2-pyflakes)
+
+ cd "${_reponame}-py2"
+
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+
+ mv "${pkgdir}/usr/bin/pyflakes" "${pkgdir}/usr/bin/pyflakes-python2"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}