summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 23:37:31 +0200
committerxantares2015-06-08 23:37:31 +0200
commit308f20728684c17bf95f4c93fc2e625554b561ac (patch)
tree112c4a93a7ad7216c13a2191783e9a8953ea2c99
downloadaur-308f20728684c17bf95f4c93fc2e625554b561ac.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..766ff20fbd44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyfprint-git
+ pkgdesc = Python bindings for the libfprint fingerprinting library
+ pkgver = r12.e682eb1
+ pkgrel = 1
+ url = https://github.com/luksan/pyfprint
+ arch = i686
+ arch = x86_64
+ license = GPL-2
+ makedepends = swig
+ depends = python
+ depends = libfprint
+ source = git+https://github.com/xantares/pyfprint.git
+ md5sums = SKIP
+
+pkgname = python-pyfprint-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db1a65e0e31b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bruno Gomes <bgomes@opens1.com>, Lucas Castro <lucas@opens1.com>
+
+pkgname=python-pyfprint-git
+pkgver=r12.e682eb1
+pkgrel=1
+pkgdesc="Python bindings for the libfprint fingerprinting library"
+url="https://github.com/luksan/pyfprint"
+arch=('i686' 'x86_64')
+license=('GPL-2')
+depends=('python' 'libfprint')
+makedepends=('swig')
+source=("git+https://github.com/xantares/pyfprint.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pyfprint"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/pyfprint"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/pyfprint"
+ python setup.py install --root=${pkgdir}
+}