summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-19 21:20:24 -0600
committerLuis Martinez2022-02-19 21:20:24 -0600
commit781ba1f670a97e34070aa95c435e6ec10b21e297 (patch)
treecd9d83e27d34b983cb5711e058db349ea317008f
parent818fdaaae41d3e4b773b98406686fc02f56c5acc (diff)
downloadaur-781ba1f670a97e34070aa95c435e6ec10b21e297.tar.gz
update to 1.13.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5823859dc0b8..cb4b20cc1c59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyfr
pkgdesc = Framework for solving advection-diffusion type problems on streaming architectures
- pkgver = 1.12.3
+ pkgver = 1.13.0
pkgrel = 1
url = https://github.com/pyfr/pyfr
arch = x86_64
@@ -25,7 +25,7 @@ pkgbase = python-pyfr
optdepends = cblas: needed for OpenMP backend
optdepends = openblas: alternative blas for OpenMP backend
optdepends = cgns: for importing CGNS meshes
- source = python-pyfr::git+https://github.com/pyfr/pyfr#commit=b556bf7?signed
+ source = python-pyfr::git+https://github.com/pyfr/pyfr#commit=ddab8b0?signed
source = 001-remove-tests.patch
validpgpkeys = AEEA6F51A3521732B684C1049E70614148A0FA1F
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2ff766d5728f..3203fd334719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: Masoud <mpoloton@gmail.com>
pkgname=python-pyfr
-pkgver=1.12.3
-_commit=b556bf7
+pkgver=1.13.0
+_commit=ddab8b0
pkgrel=1
pkgdesc="Framework for solving advection-diffusion type problems on streaming architectures"
-arch=('x86_64')
+arch=('any')
url='https://github.com/pyfr/pyfr'
license=('BSD')
depends=(
@@ -30,8 +30,13 @@ optdepends=(
'cblas: needed for OpenMP backend'
'openblas: alternative blas for OpenMP backend'
'cgns: for importing CGNS meshes')
-makedepends=('git' 'python-setuptools')
-source=("$pkgname::git+$url#commit=$_commit?signed"
+makedepends=(
+ 'git'
+ 'python-setuptools'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel')
+source=("$pkgname::git+$url#commit=${_commit}?signed"
'001-remove-tests.patch')
sha256sums=('SKIP'
'97d817a571eed6f659b9970acf45edd3c9d12d8370d0fe3d998f10cec710b10b')
@@ -45,14 +50,15 @@ prepare() {
build() {
cd "$pkgname"
- python setup.py build
+ python -m build --wheel --no-isolation
## FIXME: sphinxcontrib-contentui and sphinxcontrib-fancybox are not in the AUR
# cd doc
# make man
}
package() {
+ export PYTHONHASHSEED=0
cd "$pkgname"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}