summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarshit Shah2015-06-13 15:47:34 +0530
committerDarshit Shah2015-06-13 16:31:46 +0530
commit43cf486e090173cd3ea99ab427c061d7dbbc29ab (patch)
treebf8ab3063bcf111162d6a754e64da4de06486468
downloadaur-43cf486e090173cd3ea99ab427c061d7dbbc29ab.tar.gz
Initial import from AUR3
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be0e726d462a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pyftpdlib
+ pkgdesc = Python FTP server library
+ pkgver = 1.4.0
+ pkgrel = 3
+ url = https://github.com/giampaolo/pyftpdlib
+ arch = any
+ license = MIT
+ depends = python
+ optdepends = python-pyopenssl: required for SSL/TLS connections
+ optdepends = python-pysendfile: required for using the sendfile() call
+ source = https://github.com/giampaolo/pyftpdlib/archive/release-1.4.0.tar.gz
+ md5sums = 43ef0dd20d65443d296dc27f128a6998
+
+pkgname = python-pyftpdlib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cb3ee1d6ae04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5dbb1259600
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Submitter: Gustavo Alvarez <sl1pkn07@gmaul.com>
+#Maintainer: Darshit Shah <darnir@gmail.com>
+
+pkgname=python-pyftpdlib
+pkgver=1.4.0
+pkgrel=3
+pkgdesc="Python FTP server library"
+arch=('any')
+url="https://github.com/giampaolo/pyftpdlib"
+license=('MIT')
+source=("https://github.com/giampaolo/pyftpdlib/archive/release-${pkgver}.tar.gz")
+depends=('python')
+optdepends=("python-pyopenssl: required for SSL/TLS connections"
+ "python-pysendfile: required for using the sendfile() call")
+md5sums=('43ef0dd20d65443d296dc27f128a6998')
+
+build(){
+ cd ${srcdir}/pyftpdlib-release-${pkgver}
+ python setup.py build
+}
+
+package(){
+ cd ${srcdir}/pyftpdlib-release-${pkgver}
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}