summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2017-03-25 16:38:35 -0400
committerMatthew McGinn2017-03-25 16:39:10 -0400
commit536f53d87d0ae5689c33f710808054320167e539 (patch)
treebe13290df15f78aa5a91c3e0ea70df64018cd795
parent90e802ba861c99918bf1d265980ca57d1454eb5f (diff)
downloadaur-536f53d87d0ae5689c33f710808054320167e539.tar.gz
building latest version 1.9.3, cleaning up some PKGBUILD clutter
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f51fb7f432d..22faf16b7bad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Mar 25 20:35:18 UTC 2017
pkgbase = python-pygame
pkgdesc = Python game library
- pkgver = 1.9.2pre.20141217
- pkgrel = 1
+ pkgver = 1.9.3
+ pkgrel = 2
url = http://www.pygame.org
arch = i686
arch = x86_64
@@ -12,8 +14,8 @@ pkgbase = python-pygame
depends = sdl_image
depends = portmidi
provides = python-pygame
- source = https://bitbucket.org/pygame/pygame/get/fsencoding-ascii.tar.gz
- sha1sums = bee829579e5c08703351a7792b2648726a7798d7
+ source = https://files.pythonhosted.org/packages/source/p/pygame/pygame-1.9.3.tar.gz
+ md5sums = ac744ea6952b68d5f2b6d02a6d8e836c
pkgname = python-pygame
diff --git a/PKGBUILD b/PKGBUILD
index 0ffd5cf670b1..1b79329af441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: gryffyn
+# Maintainer: Matthew McGinn <mamcgi@gmail.com>
+# Contributor: Gryffyn
+# Contributor: Tetsumi
-pkgbase=python-pygame
pkgname=python-pygame
-pkgver=1.9.2pre.20141217
-pkgrel=1
+_name=pygame
+pkgver=1.9.3
+pkgrel=2
pkgdesc="Python game library"
arch=('i686' 'x86_64')
url="http://www.pygame.org"
@@ -11,13 +13,13 @@ license=('LGPL')
depends=('python' 'sdl_mixer' 'sdl_ttf' 'sdl_image' 'portmidi')
provides=('python-pygame')
-source=(https://bitbucket.org/pygame/pygame/get/fsencoding-ascii.tar.gz)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha1sums=('bee829579e5c08703351a7792b2648726a7798d7')
+md5sums=('ac744ea6952b68d5f2b6d02a6d8e836c')
package()
{
- cd pygame-pygame-64f9038c292d
+ cd ${_name}-${pkgver}
python config.py -auto
python setup.py install --root="${pkgdir}" --prefix=/usr
}