summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTetsumi2015-09-21 14:05:25 +0200
committerTetsumi2015-09-21 14:05:25 +0200
commit72182bc77a9293d9c9daf6851882da60e0095ba8 (patch)
tree398609fe447dcf6879583f6158fbe755955f4822
downloadaur-72182bc77a9293d9c9daf6851882da60e0095ba8.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--pygame-config.patch26
-rw-r--r--pygame-joystick.patch43
-rw-r--r--pygame-v4l.patch88
5 files changed, 221 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..258fb9558756
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-pygame
+ pkgdesc = Python game library
+ pkgver = 1.9.1
+ pkgrel = 1
+ url = http://www.pygame.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = python
+ depends = sdl_mixer
+ depends = sdl_ttf
+ depends = sdl_image
+ depends = portmidi
+ provides = python-pygame
+ source = http://www.pygame.org/ftp/pygame-1.9.1release.tar.gz
+ source = pygame-config.patch
+ source = pygame-v4l.patch
+ source = pygame-joystick.patch
+ sha1sums = a45aeb0623e36ae7a1707b5f41ee6274f72ca4fa
+ sha1sums = 285815e28705d5a2aea53c9d952d35fddf10dd13
+ sha1sums = 7e693fb2ef5ef636f9965ba1a4eb854f8b0b5070
+ sha1sums = 399ef25b9bdcda7eb35f0147dffcfc4886405c36
+
+pkgname = python-pygame
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..462040994a92
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Tetsumi <tetsumi@vmail.me>
+
+pkgbase=python-pygame
+pkgname=python-pygame
+pkgver=1.9.1
+pkgrel=1
+pkgdesc="Python game library"
+arch=('i686' 'x86_64')
+url="http://www.pygame.org"
+license=('LGPL')
+depends=('python' 'sdl_mixer' 'sdl_ttf' 'sdl_image' 'portmidi')
+provides=('python-pygame')
+
+source=(http://www.pygame.org/ftp/pygame-${pkgver}release.tar.gz
+ pygame-config.patch
+ pygame-v4l.patch
+ pygame-joystick.patch
+)
+
+sha1sums=('a45aeb0623e36ae7a1707b5f41ee6274f72ca4fa'
+ '285815e28705d5a2aea53c9d952d35fddf10dd13'
+ '7e693fb2ef5ef636f9965ba1a4eb854f8b0b5070'
+ '399ef25b9bdcda7eb35f0147dffcfc4886405c36')
+
+prepare()
+{
+ cd pygame-${pkgver}release
+ patch -p0 -i "${srcdir}/pygame-config.patch"
+ patch -p1 -i "${srcdir}/pygame-v4l.patch"
+ patch -p1 -i "${srcdir}/pygame-joystick.patch"
+}
+
+
+package()
+{
+ cd pygame-${pkgver}release
+ python config.py -auto
+ python setup.py install --root="${pkgdir}" --prefix=/usr
+}
diff --git a/pygame-config.patch b/pygame-config.patch
new file mode 100644
index 000000000000..b3dab162ce0e
--- /dev/null
+++ b/pygame-config.patch
@@ -0,0 +1,26 @@
+Index: config_unix.py
+===================================================================
+--- config_unix.py (revision 2567)
++++ config_unix.py (working copy)
+@@ -174,7 +174,7 @@
+
+ for d in DEPS[1:]:
+ if not d.found:
+- if not confirm("""
++ if "-auto" not in sys.argv and not confirm("""
+ Warning, some of the pygame dependencies were not found. Pygame can still
+ compile and install, but games that depend on those missing dependencies
+ will not run. Would you like to continue the configuration?"""):
+Index: config_msys.py
+===================================================================
+--- config_msys.py (revision 2567)
++++ config_msys.py (working copy)
+@@ -283,7 +283,7 @@
+
+ for d in DEPS[1:]:
+ if not d.found:
+- if not confirm("""
++ if "-auto" not in sys.argv and not confirm("""
+ Warning, some of the pygame dependencies were not found. Pygame can still
+ compile and install, but games that depend on those missing dependencies
+ will not run. Would you like to continue the configuration?"""):
diff --git a/pygame-joystick.patch b/pygame-joystick.patch
new file mode 100644
index 000000000000..79d671b156b2
--- /dev/null
+++ b/pygame-joystick.patch
@@ -0,0 +1,43 @@
+diff -Naur pygame-1.9.1release-orig/src/joystick.c pygame-1.9.1release/src/joystick.c
+--- pygame-1.9.1release-orig/src/joystick.c 2015-02-09 23:43:06.683066782 -0500
++++ pygame-1.9.1release/src/joystick.c 2015-02-09 23:54:40.758606974 -0500
+@@ -201,7 +201,6 @@
+ }
+
+ value = SDL_JoystickGetAxis (joy, axis);
+- printf("SDL_JoystickGetAxis value:%d:\n", value);
+
+
+ return PyFloat_FromDouble (value / 32768.0);
+@@ -241,7 +240,6 @@
+ }
+
+ value = SDL_JoystickGetButton (joy, _index);
+- printf("SDL_JoystickGetButton value:%d:\n", value);
+
+ return PyInt_FromLong (value);
+ }
+@@ -277,7 +275,6 @@
+ return RAISE (PyExc_SDLError, "Joystick not initialized");
+ }
+ value = SDL_JoystickNumBalls (joy);
+- printf("SDL_JoystickNumBalls value:%d:\n", value);
+
+ if (_index < 0 || _index >= value) {
+ return RAISE (PyExc_SDLError, "Invalid joystick trackball");
+@@ -300,7 +297,6 @@
+ }
+
+ value = SDL_JoystickNumHats (joy);
+- printf("SDL_JoystickNumHats value:%d:\n", value);
+
+ return PyInt_FromLong (value);
+ }
+@@ -327,7 +323,6 @@
+
+ px = py = 0;
+ value = SDL_JoystickGetHat (joy, _index);
+- printf("SDL_JoystickGetHat value:%d:\n", value);
+
+ if (value & SDL_HAT_UP) {
+ py = 1;
diff --git a/pygame-v4l.patch b/pygame-v4l.patch
new file mode 100644
index 000000000000..3b5a2b9d2bf9
--- /dev/null
+++ b/pygame-v4l.patch
@@ -0,0 +1,88 @@
+diff -crB pygame-1.9.1release/Setup.in pygame-1.9.1release-v4lpatch//Setup.in
+*** pygame-1.9.1release/Setup.in Thu Jul 2 06:41:56 2009
+--- pygame-1.9.1release-v4lpatch//Setup.in Thu Mar 24 17:31:22 2011
+***************
+*** 34,40 ****
+ _numericsndarray src/_numericsndarray.c $(SDL) $(MIXER) $(DEBUG)
+ movie src/movie.c $(SDL) $(SMPEG) $(DEBUG)
+ scrap src/scrap.c $(SDL) $(SCRAP) $(DEBUG)
+! _camera src/_camera.c src/camera_v4l2.c src/camera_v4l.c $(SDL) $(DEBUG)
+ pypm src/pypm.c $(SDL) $(PORTMIDI) $(PORTTIME) $(DEBUG)
+
+ GFX = src/SDL_gfx/SDL_gfxPrimitives.c
+--- 34,40 ----
+ _numericsndarray src/_numericsndarray.c $(SDL) $(MIXER) $(DEBUG)
+ movie src/movie.c $(SDL) $(SMPEG) $(DEBUG)
+ scrap src/scrap.c $(SDL) $(SCRAP) $(DEBUG)
+! _camera src/_camera.c src/camera_v4l2.c $(SDL) $(DEBUG)
+ pypm src/pypm.c $(SDL) $(PORTMIDI) $(PORTTIME) $(DEBUG)
+
+ GFX = src/SDL_gfx/SDL_gfxPrimitives.c
+diff -crB pygame-1.9.1release/src/_camera.c pygame-1.9.1release-v4lpatch//src/_camera.c
+*** pygame-1.9.1release/src/_camera.c Sun Mar 15 20:30:41 2009
+--- pygame-1.9.1release-v4lpatch//src/_camera.c Thu Mar 24 16:58:18 2011
+***************
+*** 160,179 ****
+ {
+ #if defined(__unix__)
+ if (v4l2_open_device(self) == 0) {
+! if (v4l_open_device(self) == 0) {
+! v4l2_close_device(self);
+! return NULL;
+! } else {
+! self->camera_type = CAM_V4L;
+! if (v4l_init_device(self) == 0) {
+! v4l2_close_device(self);
+! return NULL;
+! }
+! if (v4l_start_capturing(self) == 0) {
+! v4l2_close_device(self);
+! return NULL;
+! }
+! }
+ } else {
+ self->camera_type = CAM_V4L2;
+ if (v4l2_init_device(self) == 0) {
+--- 160,167 ----
+ {
+ #if defined(__unix__)
+ if (v4l2_open_device(self) == 0) {
+! v4l2_close_device(self);
+! return NULL;
+ } else {
+ self->camera_type = CAM_V4L2;
+ if (v4l2_init_device(self) == 0) {
+diff -crB pygame-1.9.1release/src/camera.h pygame-1.9.1release-v4lpatch//src/camera.h
+*** pygame-1.9.1release/src/camera.h Fri Oct 10 04:37:10 2008
+--- pygame-1.9.1release-v4lpatch//src/camera.h Thu Mar 24 16:44:32 2011
+***************
+*** 39,45 ****
+
+ #include <asm/types.h> /* for videodev2.h */
+
+- #include <linux/videodev.h>
+ #include <linux/videodev2.h>
+ #endif
+
+--- 39,44 ----
+***************
+*** 51,57 ****
+ #define RGB_OUT 1
+ #define YUV_OUT 2
+ #define HSV_OUT 4
+- #define CAM_V4L 1
+ #define CAM_V4L2 2
+
+ struct buffer
+--- 50,55 ----
+***************
+*** 111,118 ****
+ int v4l2_close_device (PyCameraObject* self);
+ int v4l2_open_device (PyCameraObject* self);
+
+- /* internal functions specific to v4l */
+- int v4l_open_device (PyCameraObject* self);
+- int v4l_init_device(PyCameraObject* self);
+- int v4l_start_capturing(PyCameraObject* self);
+ #endif
+--- 109,112 ----