summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-03-03 19:19:54 +0100
committerFabioLolix2020-03-03 19:19:54 +0100
commit3a97982d9d2897c0b1cc55a4044ef71037f28754 (patch)
tree7abe2751673c0dcdc343f97bba30465524edda5d
parentc86c8b63a607bf61feed5e4b8fcf93c19b12cb2e (diff)
downloadaur-3a97982d9d2897c0b1cc55a4044ef71037f28754.tar.gz
revision
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d69e47213992..880e2bea8173 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-pygccxml
pkgdesc = Simple framework to navigate C++ declarations, using Python classes.
pkgver = 1.9.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gccxml/pygccxml
arch = any
license = Boost
- checkdepends = python-pycodestyle
makedepends = python-setuptools
depends = castxml
depends = python
+ provides = pygccxml
+ replaces = pygccxml
source = python-pygccxml-1.9.1.tar.gz::https://github.com/gccxml/pygccxml/archive/v1.9.1.tar.gz
sha256sums = 2fb4e18f7a3ae039a05230ca58f11e1fc925c8643f926a1be481bb4338414a95
diff --git a/PKGBUILD b/PKGBUILD
index 7a9879e865dd..cb3000cfd49a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: Yunhui Fu <yhfudev at gmail dot com>
# Contributor: Benjamin Chretien <chretien at lirmm dot fr>
# Contributor: zarra <zarraxx@gmail.com>
pkgname=python-pygccxml
pkgver=1.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple framework to navigate C++ declarations, using Python classes."
arch=(any)
url="https://github.com/gccxml/pygccxml"
license=(Boost)
depends=(castxml python)
makedepends=(python-setuptools)
-checkdepends=(python-pycodestyle)
+#checkdepends=(python-pycodestyle)
+provides=(pygccxml)
+replaces=(pygccxml)
source=("$pkgname-$pkgver.tar.gz::https://github.com/gccxml/pygccxml/archive/v${pkgver}.tar.gz")
sha256sums=('2fb4e18f7a3ae039a05230ca58f11e1fc925c8643f926a1be481bb4338414a95')
@@ -20,10 +23,10 @@ build() {
python setup.py build
}
-check() {
- cd "${srcdir}/pygccxml-${pkgver}"
- python -m unittests.test_all
-}
+#check() {
+# cd "${srcdir}/pygccxml-${pkgver}"
+# python -m unittests.test_all
+#}
package() {
cd "${srcdir}/pygccxml-${pkgver}"