summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-05-28 23:59:15 +0200
committerFabioLolix2021-05-28 23:59:15 +0200
commite1afedb88e4c3cd10a67c69659cfb77760bd582f (patch)
tree94d2955e3171e1d5f00850adce029c64c7bbc07a
parent3a97982d9d2897c0b1cc55a4044ef71037f28754 (diff)
downloadaur-e1afedb88e4c3cd10a67c69659cfb77760bd582f.tar.gz
v2.2.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 880e2bea8173..2e7b3dac1550 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-pygccxml
pkgdesc = Simple framework to navigate C++ declarations, using Python classes.
- pkgver = 1.9.1
- pkgrel = 2
+ pkgver = 2.2.1
+ pkgrel = 1
url = https://github.com/gccxml/pygccxml
arch = any
license = Boost
+ checkdepends = python-pycodestyle
makedepends = python-setuptools
depends = castxml
depends = python
provides = pygccxml
replaces = pygccxml
- source = python-pygccxml-1.9.1.tar.gz::https://github.com/gccxml/pygccxml/archive/v1.9.1.tar.gz
- sha256sums = 2fb4e18f7a3ae039a05230ca58f11e1fc925c8643f926a1be481bb4338414a95
+ source = python-pygccxml-2.2.1.tar.gz::https://github.com/gccxml/pygccxml/archive/v2.2.1.tar.gz
+ sha256sums = 9815a12e3bf6b83b2e9d8c88335fb3fa0e2b4067d7fbaaed09c3bf26c6206cc7
pkgname = python-pygccxml
diff --git a/PKGBUILD b/PKGBUILD
index cb3000cfd49a..1d9590d36eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@
# Contributor: zarra <zarraxx@gmail.com>
pkgname=python-pygccxml
-pkgver=1.9.1
-pkgrel=2
+pkgver=2.2.1
+pkgrel=1
pkgdesc="Simple framework to navigate C++ declarations, using Python classes."
arch=(any)
url="https://github.com/gccxml/pygccxml"
license=(Boost)
depends=(castxml python)
makedepends=(python-setuptools)
-#checkdepends=(python-pycodestyle)
+checkdepends=(python-pycodestyle)
provides=(pygccxml)
replaces=(pygccxml)
source=("$pkgname-$pkgver.tar.gz::https://github.com/gccxml/pygccxml/archive/v${pkgver}.tar.gz")
-sha256sums=('2fb4e18f7a3ae039a05230ca58f11e1fc925c8643f926a1be481bb4338414a95')
+sha256sums=('9815a12e3bf6b83b2e9d8c88335fb3fa0e2b4067d7fbaaed09c3bf26c6206cc7')
build() {
cd "${srcdir}/pygccxml-${pkgver}"
@@ -30,5 +30,5 @@ build() {
package() {
cd "${srcdir}/pygccxml-${pkgver}"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ python setup.py install --skip-build --optimize=1 --prefix=/usr --root="${pkgdir}"
}