summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2022-12-03 22:35:41 +0600
committerMubashshir2022-12-03 22:36:29 +0600
commit1e82a205ea921c93ba54142cc598cf2e476e6b22 (patch)
tree4810b843434c9f22b8c6f8d78bba734a24d435b6
parentc1768f190547e8cc0dc36bd7b2e9b10401d5ccca (diff)
downloadaur-1e82a205ea921c93ba54142cc598cf2e476e6b22.tar.gz
python-pyglm: Fix build failure due to missing submodule
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD37
2 files changed, 34 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ed2067c9b9c..4aca3883fa31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = python-pyglm
pkgdesc = OpenGL Mathematics library for Python
pkgver = 2.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Zuzu-Typ/PyGLM
arch = any
license = ZLIB
makedepends = python-setuptools
+ makedepends = git
depends = python
- source = https://files.pythonhosted.org/packages/source/P/PyGLM/PyGLM-2.6.0.tar.gz
- sha256sums = f853abad66ec78602a9e9693d81a6ba6579a0cbe71715bf89f6bc62cbc837170
+ source = python-pyglm::git+https://github.com/Zuzu-Typ/PyGLM.git#tag=2.6.0
+ source = pyglm-typing::git+https://github.com/esoma/pyglm-typing.git
+ source = glm::git+https://github.com/Zuzu-Typ/glm.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = python-pyglm
- depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 83dd289d9c6c..c8dd509cf96c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,42 @@
# from: pypi
# what: PyGLM
-pkgbase='python-pyglm'
-pkgname=('python-pyglm')
-_module='PyGLM'
+pkgname='python-pyglm'
pkgver='2.6.0'
-pkgrel=1
+pkgrel=2
pkgdesc="OpenGL Mathematics library for Python"
url="https://github.com/Zuzu-Typ/PyGLM"
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'git')
license=('ZLIB')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('f853abad66ec78602a9e9693d81a6ba6579a0cbe71715bf89f6bc62cbc837170')
+source=(
+ "$pkgname::git+https://github.com/Zuzu-Typ/PyGLM.git#tag=$pkgver"
+ "pyglm-typing::git+https://github.com/esoma/pyglm-typing.git"
+ "glm::git+https://github.com/Zuzu-Typ/glm.git"
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ local mod
+
+ cd "$srcdir/$pkgname"
+ git submodule init
+ for mod in glm pyglm-typing; do
+ git config "submodule.$mod.url" "$srcdir/$mod"
+ done
+
+ git -c protocol.file.allow=always submodule update
+}
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd "$srcdir/$pkgname"
+ CFLAGS="$CFLAGS -Wno-all" python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "$srcdir/$pkgname"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}