summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorholishing2020-05-07 01:36:37 +0800
committerholishing2020-05-07 01:36:37 +0800
commit2c6e3886199862859ceca7b16ff560641e4c579e (patch)
treec1dfb81d600df4c82b50cf8dad3715926fdb83c3
parent2f58328d7e0b6d0c2eafaf58ca36d3531a2a2a14 (diff)
downloadaur-2c6e3886199862859ceca7b16ff560641e4c579e.tar.gz
bumped version to v0.1.0
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD30
2 files changed, 35 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f7cece84af5..fc353b90ed84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,37 @@
pkgbase = python-pygmt
pkgdesc = Python interface to the Generic Mapping Tools C library
- pkgver = 0.0.1a0_20191103
+ pkgver = 0.1.0
pkgrel = 1
url = https://www.pygmt.org
arch = x86_64
license = 3-BSD
makedepends = cython
makedepends = python-setuptools
+ makedepends = gmt-coast
+ makedepends = gmt-dcw
+ makedepends = ipython
+ makedepends = python-matplotlib
+ makedepends = jupyter
+ makedepends = python-pytest
+ makedepends = python-pytest-cov
+ makedepends = python-pytest-mpl
+ makedepends = python-coverage
+ makedepends = python-black
+ makedepends = python-pylint
+ makedepends = flake8
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
+ makedepends = python-sphinx-gallery
+ makedepends = python-nbsphinx
+ makedepends = python-numpydoc
depends = python-numpy
depends = python-pandas
depends = python-xarray
depends = python-netcdf4
depends = python-packaging
- depends = gmt>=6.0.0
- optdepends = gmt-coast
- optdepends = gmt-dcw
- optdepends = ipython
- optdepends = python-matplotlib
- optdepends = jupyter
- optdepends = python-pytest
- optdepends = python-pytest-cov
- optdepends = python-pytest-mpl
- optdepends = python-coverage
- optdepends = python-black
- optdepends = python-pylint
- optdepends = flake8
- optdepends = python-sphinx
- optdepends = python-sphinx_rtd_theme
- optdepends = python-sphinx-gallery
- optdepends = python-nbsphinx
- optdepends = python-numpydoc
- source = https://github.com/GenericMappingTools/pygmt/archive/55af9b67b5f04a1cde30cba013eec31d44874d4f.tar.gz
- sha256sums = e2111299a2674427754d37d75fed1c9af107fcb07d8fb493ef09a07f3f89dc3d
+ depends = gmt6>=6.0.0
+ source = https://github.com/GenericMappingTools/pygmt/archive/v0.1.0.tar.gz
+ sha256sums = 2798b95cadd29dace71f5b888981ba2b86f351da1397beefa64d119b666ffb14
pkgname = python-pygmt
diff --git a/PKGBUILD b/PKGBUILD
index b4ca32178e27..36f9bad2c18e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,41 @@
# Maintainer: Sean Ho <sean.li.shin.ho@gmail.com>
_pkg=pygmt
-pkgbase=python-${_pkg,,}
-pkgname=("python-${_pkg,,}")
-pkghashver=55af9b67b5f04a1cde30cba013eec31d44874d4f
-pkgdate=20191103
-pkgver=0.0.1a0_${pkgdate}
+pkgbase=python-${_pkg}
+pkgname=("python-${_pkg}")
+pkgver=0.1.0
pkgrel=1
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0')
-makedepends=('cython' 'python-setuptools')
-optdepends=('gmt-coast' 'gmt-dcw' 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6>=6.0.0')
+makedepends=('cython' 'python-setuptools'
+ 'gmt-coast' 'gmt-dcw' 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
'python-black' 'python-pylint' 'flake8' 'python-sphinx'
'python-sphinx_rtd_theme' 'python-sphinx-gallery'
'python-nbsphinx' 'python-numpydoc')
-source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/${pkghashver}.tar.gz")
-sha256sums=('e2111299a2674427754d37d75fed1c9af107fcb07d8fb493ef09a07f3f89dc3d')
+source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/v${pkgver}.tar.gz")
+sha256sums=('2798b95cadd29dace71f5b888981ba2b86f351da1397beefa64d119b666ffb14')
build() {
- cd ${_pkg}-${pkghashver}
+ cd ${_pkg}-${pkgver}
USE_NCCONFIG=1 python setup.py build
}
-#check() {
+check() {
# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
# 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
# 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
# 'python-nbsphinx' 'python-numpydoc')
-# cd ${_pkg}-${pkghashver}
-# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()'
-#}
+ cd ${_pkg}-${pkgver}
+ PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()' || return 0
+}
package() {
- cd ${_pkg}-${pkghashver}
+ cd ${_pkg}-${pkgver}
USE_NCCONFIG=1 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=2
}