summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorholishing2021-06-24 02:26:22 +0800
committerholishing2021-06-24 02:26:22 +0800
commit3bfab81b405c84a758e45ef8b5eddb0f539ebd39 (patch)
treefcb03c868005daa97d6c307d1ab7e68c634d2f5a
parent8231ac4f59f79e613390e9762d5a481313fff377 (diff)
downloadaur-3bfab81b405c84a758e45ef8b5eddb0f539ebd39.tar.gz
remove check section
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD39
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fe7154b6a07..637f2cfe9053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pygmt
pkgdesc = Python interface to the Generic Mapping Tools C library
pkgver = 0.4.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.pygmt.org
arch = x86_64
license = 3-BSD
@@ -37,7 +37,7 @@ pkgbase = python-pygmt
depends = python-xarray
depends = python-netcdf4
depends = python-packaging
- depends = gmt6>=6.1.1
+ depends = gmt>=6.1.1
source = https://github.com/GenericMappingTools/pygmt/archive/v0.4.0.tar.gz
sha256sums = 65344f1316587896b17708e1a064a0c6976db40ed7b3394e4a35500cd8ae7ea8
diff --git a/PKGBUILD b/PKGBUILD
index f012d333c824..070b97bb0d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,21 @@ _pkg=pygmt
pkgbase=python-${_pkg}
pkgname=("python-${_pkg}")
pkgver=0.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6>=6.1.1')
-makedepends=('python-pip' 'cython' 'python-setuptools'
- 'gmt-coast' 'gmt-dcw' 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
- 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
- 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
- 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
- 'python-nbsphinx' 'python-numpydoc' 'python-docformatter'
- 'python-black' 'python-blackdoc' 'dvc' 'python-isort'
- 'python-myst-parser' 'python-sphinx-copybutton' )
+depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.1.1')
+makedepends=('python-pip' 'cython' 'python-setuptools')
+ #'gmt-coast' 'gmt-dcw'
+ #'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+ #'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
+ #'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+ #'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+ #'python-nbsphinx' 'python-numpydoc' 'python-docformatter'
+ #'python-black' 'python-blackdoc' 'dvc' 'python-isort'
+ #'python-myst-parser' 'python-sphinx-copybutton' )
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/v${pkgver}.tar.gz")
sha256sums=('65344f1316587896b17708e1a064a0c6976db40ed7b3394e4a35500cd8ae7ea8')
@@ -27,15 +28,15 @@ build() {
USE_NCCONFIG=1 python setup.py build
}
-check() {
-# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
-# 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
-# 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
-# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
-# 'python-nbsphinx' 'python-numpydoc')
- cd ${_pkg}-${pkgver}
- PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()' || return 0
-}
+#check() {
+## depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+## 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
+## 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+## 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+## 'python-nbsphinx' 'python-numpydoc')
+# cd ${_pkg}-${pkgver}
+# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()' || true
+#}
package() {
cd ${_pkg}-${pkgver}