summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsean09212019-04-23 04:41:28 +0000
committersean09212019-04-23 04:41:28 +0000
commit5c1c3122a560efad811c5c04e2c2ac96e49847c8 (patch)
tree55313132dcbff1c924297444a4a653f385394b64
parente4b200077fb5667638ed1a85df491ae346d8b908 (diff)
downloadaur-5c1c3122a560efad811c5c04e2c2ac96e49847c8.tar.gz
fixing check() operation and add dependS
but not run test by default 'cause of some problem
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd3e4afc7af1..f776c2478531 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
#numpy, pandas, xarray, netCDF4, packaging
-makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0'
+makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw'
'ipython' 'python-matplotlib' 'jupyter' 'python-pytest' 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage' 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
'python-sphinx_rtd_theme' 'python-sphinx-gallery' 'python-nbsphinx' 'python-numpydoc')
source=("https://files.pythonhosted.org/packages/77/72/5dfc13ff2be531366a735047892f8c99d709f1289c1eb5f4d0f656b35ce6/pygmt-${pkgver}.tar.gz")
@@ -22,12 +22,12 @@ build() {
}
#check() {
-# cd ${_pkg}-${pkgver}/pygmt/tests
-# PYTHONPATH="../build/lib.linux-${CARCH}-3.7" python -B ./run_all.py
+# cd ${_pkg}-${pkgver}
+# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()'
#}
package() {
- depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0')
+ depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw')
cd ${_pkg}-${pkgver}
USE_NCCONFIG=1 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=2