summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsean09212019-04-23 04:45:34 +0800
committersean09212019-04-23 04:45:34 +0800
commit6192d75852ee14a5d25089628289d5ed73c46b38 (patch)
tree54a1efeab6b748df33a900de7098ec86cb45e2eb
downloadaur-6192d75852ee14a5d25089628289d5ed73c46b38.tar.gz
Initial Commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bc3611fda33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-pygmt
+ pkgdesc = Python/NumPy interface to the netCDF C library
+ pkgver = 0.0.1a0
+ pkgrel = 1
+ url = https://www.pygmt.org
+ arch = x86_64
+ license = 3-BSD
+ makedepends = cython
+ makedepends = python-setuptools
+ makedepends = python-numpy
+ makedepends = python-pandas
+ makedepends = python-xarray
+ makedepends = python-netcdf4
+ makedepends = python-packaging
+ makedepends = gmt
+ source = https://files.pythonhosted.org/packages/77/72/5dfc13ff2be531366a735047892f8c99d709f1289c1eb5f4d0f656b35ce6/pygmt-0.0.1a0.tar.gz
+ sha256sums = 0bba865dea5cedcbac52ece31775ddf9b1c2bf1629e585cd6bc1fce848b09add
+
+pkgname = python-pygmt
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-xarray
+ depends = python-netcdf4
+ depends = python-packaging
+ depends = gmt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23ff8240d006
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bruno Pagani <archange@archlinux.org>
+# Contributor: Spyros Stathopoulos <foucault.online@gmail.com>
+# Contributor: richli <rich at dranek dot com>
+# Contributor: rememberthemer <rememberthemer@_GMAIL_DOT_COM_>
+
+_pkg=pygmt
+pkgbase=python-${_pkg,,}
+pkgname=("python-${_pkg,,}")
+pkgver=0.0.1a0
+pkgrel=1
+pkgdesc="Python/NumPy interface to the netCDF C library"
+arch=('x86_64')
+url="https://www.pygmt.org"
+license=('3-BSD')
+#numpy, pandas, xarray, netCDF4, packaging
+makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt')
+source=("https://files.pythonhosted.org/packages/77/72/5dfc13ff2be531366a735047892f8c99d709f1289c1eb5f4d0f656b35ce6/pygmt-${pkgver}.tar.gz")
+sha256sums=('0bba865dea5cedcbac52ece31775ddf9b1c2bf1629e585cd6bc1fce848b09add')
+
+build() {
+ cd ${_pkg}-${pkgver}
+ USE_NCCONFIG=1 python setup.py build
+}
+
+#check() {
+# cd ${_pkg}-${pkgver}/pygmt/tests
+# PYTHONPATH="../build/lib.linux-${CARCH}-3.7" python -B ./run_all.py
+#}
+
+package() {
+ depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt')
+
+ cd ${_pkg}-${pkgver}
+ USE_NCCONFIG=1 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=2
+}