summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsean09212021-11-19 23:24:40 +0800
committersean09212021-11-19 23:24:40 +0800
commitbba5fbb152bbab5d024e08f2a5dcec9c6089dca5 (patch)
tree70e24320547660f1392129677691491e6bba9d63
parent65e4645593b0e9d6ccae64fe38c32816c9efff9c (diff)
downloadaur-bba5fbb152bbab5d024e08f2a5dcec9c6089dca5.tar.gz
bumped version to 0.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31ce595c8398..a8b7ee54ff13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pygmt
pkgdesc = Python interface to the Generic Mapping Tools C library
- pkgver = 0.4.0
- pkgrel = 4
+ pkgver = 0.5.0
+ pkgrel = 1
url = https://www.pygmt.org
arch = x86_64
license = 3-BSD
@@ -13,8 +13,8 @@ pkgbase = python-pygmt
depends = python-xarray
depends = python-netcdf4
depends = python-packaging
- depends = gmt>=6.1.1
- source = https://github.com/GenericMappingTools/pygmt/archive/v0.4.0.tar.gz
- sha256sums = 65344f1316587896b17708e1a064a0c6976db40ed7b3394e4a35500cd8ae7ea8
+ depends = gmt>=6.2.0
+ source = https://github.com/GenericMappingTools/pygmt/archive/v0.5.0.tar.gz
+ sha256sums = b1cc8037cd5c684253ca4129cbccc6157d321105c348b6bf2acf3b8e38e59bb7
pkgname = python-pygmt
diff --git a/PKGBUILD b/PKGBUILD
index 070b97bb0d66..945b02883d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkg=pygmt
pkgbase=python-${_pkg}
pkgname=("python-${_pkg}")
-pkgver=0.4.0
-pkgrel=4
+pkgver=0.5.0
+pkgrel=1
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.1.1')
+depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.2.0')
makedepends=('python-pip' 'cython' 'python-setuptools')
#'gmt-coast' 'gmt-dcw'
#'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
@@ -21,7 +21,7 @@ makedepends=('python-pip' 'cython' 'python-setuptools')
#'python-myst-parser' 'python-sphinx-copybutton' )
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/v${pkgver}.tar.gz")
-sha256sums=('65344f1316587896b17708e1a064a0c6976db40ed7b3394e4a35500cd8ae7ea8')
+sha256sums=('b1cc8037cd5c684253ca4129cbccc6157d321105c348b6bf2acf3b8e38e59bb7')
build() {
cd ${_pkg}-${pkgver}