summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsean09212022-07-02 18:50:53 +0800
committersean09212022-07-02 18:50:53 +0800
commitc282523bfa5c713bdb28e5ed4b2228403a933133 (patch)
tree3ee07ee559d07ea9a275e9cf3f97727fb90b305f
parent8a228ae5e8e9e2f801131a3ab737b0e9318b4dae (diff)
downloadaur-c282523bfa5c713bdb28e5ed4b2228403a933133.tar.gz
bumped version to 0.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9545f498d0ab..17b34495d2cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pygmt
pkgdesc = Python interface to the Generic Mapping Tools C library
- pkgver = 0.6.1
+ pkgver = 0.7.0
pkgrel = 1
url = https://www.pygmt.org
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = python-pygmt
depends = python-xarray
depends = python-netcdf4
depends = python-packaging
- depends = gmt>=6.2.0
- source = https://github.com/GenericMappingTools/pygmt/archive/v0.6.1.tar.gz
- sha256sums = e3d6c3749f5ebed2920ddd12ed455c531ee1eee35c9190aad68806db7d54b8b0
+ depends = gmt
+ source = https://github.com/GenericMappingTools/pygmt/archive/v0.7.0.tar.gz
+ sha256sums = 0228497efbea0dabdd06294e3c65d7fb6e0cf7964617c0f29bd417d68e2c9425
pkgname = python-pygmt
diff --git a/PKGBUILD b/PKGBUILD
index a6ec440dd715..ad9a4061cd60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkg=pygmt
pkgbase=python-${_pkg}
pkgname=("python-${_pkg}")
-pkgver=0.6.1
+pkgver=0.7.0
pkgrel=1
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.2.0')
+depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt')
makedepends=('python-pip' 'cython' 'python-setuptools')
#'gmt-coast' 'gmt-dcw'
#'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
@@ -21,7 +21,7 @@ makedepends=('python-pip' 'cython' 'python-setuptools')
#'python-myst-parser' 'python-sphinx-copybutton' )
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/v${pkgver}.tar.gz")
-sha256sums=('e3d6c3749f5ebed2920ddd12ed455c531ee1eee35c9190aad68806db7d54b8b0')
+sha256sums=('0228497efbea0dabdd06294e3c65d7fb6e0cf7964617c0f29bd417d68e2c9425')
build() {
cd ${_pkg}-${pkgver}