summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsean09212019-05-18 14:55:14 +0800
committersean09212019-05-18 14:55:14 +0800
commitc846163ce423f4fadb161ec9fa888ad44c8fbdcc (patch)
treef9628de4c5699d8d4435871b73230837edcc6e5a
parentf5d08277e0aacbb0c1dfbeb7a6959aaa9474b82c (diff)
downloadaur-c846163ce423f4fadb161ec9fa888ad44c8fbdcc.tar.gz
move gmt-coast gmt-dcw to optional
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD14
2 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9be1fa910122..0f047151de6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pygmt
pkgdesc = Python interface to the Generic Mapping Tools C library
pkgver = 0.0.1a0_997b88c855c12ffacd2c4b911f3fa83244ce8d7b
- pkgrel = 3
+ pkgrel = 4
url = https://www.pygmt.org
arch = x86_64
license = 3-BSD
@@ -13,8 +13,23 @@ pkgbase = python-pygmt
depends = python-netcdf4
depends = python-packaging
depends = gmt6
- depends = gmt-coast
- depends = gmt-dcw
+ optdepends = gmt-coast
+ optdepends = gmt-dcw
+ optdepends = ipython
+ optdepends = python-matplotlib
+ optdepends = jupyter
+ optdepends = python-pytest
+ optdepends = python-pytest-cov
+ optdepends = python-pytest-mpl
+ optdepends = python-coverage
+ optdepends = python-black
+ optdepends = python-pylint
+ optdepends = flake8
+ optdepends = python-sphinx
+ optdepends = python-sphinx_rtd_theme
+ optdepends = python-sphinx-gallery
+ optdepends = python-nbsphinx
+ optdepends = python-numpydoc
source = https://github.com/GenericMappingTools/pygmt/archive/997b88c855c12ffacd2c4b911f3fa83244ce8d7b.tar.gz
sha256sums = 990145de2d61df5d02f784e406a217138ee029f559454bcf7eb12a28f6258a60
diff --git a/PKGBUILD b/PKGBUILD
index 8756354932e1..6701b7f4e840 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,19 @@ pkgbase=python-${_pkg,,}
pkgname=("python-${_pkg,,}")
pkghashver=997b88c855c12ffacd2c4b911f3fa83244ce8d7b
pkgver=0.0.1a0_${pkghashver}
-pkgrel=3
+pkgrel=4
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6' 'gmt-coast' 'gmt-dcw')
+depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6')
makedepends=('cython' 'python-setuptools')
+optdepends=('gmt-coast' 'gmt-dcw' 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+ 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
+ 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+ 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+ 'python-nbsphinx' 'python-numpydoc')
+
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/${pkghashver}.tar.gz")
sha256sums=('990145de2d61df5d02f784e406a217138ee029f559454bcf7eb12a28f6258a60')
@@ -21,10 +27,10 @@ build() {
}
#check() {
-# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
# 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
# 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
-# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
# 'python-nbsphinx' 'python-numpydoc')
# cd ${_pkg}-${pkghashver}
# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()'