summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorholishing2021-06-21 11:38:14 +0800
committerholishing2021-06-21 11:38:14 +0800
commitd32cd412b3ada3398bfb1c3b684a27f5b5fd4cb9 (patch)
treed9cd39f89b3dff7c084a63d3a3250e33a8ac4140
parent18cd82edace5f1bfcb0aecc1d69c8bd4657b2d5d (diff)
downloadaur-d32cd412b3ada3398bfb1c3b684a27f5b5fd4cb9.tar.gz
add make test dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c776298b206..8476666863cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pygmt
pkgdesc = Python interface to the Generic Mapping Tools C library
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.pygmt.org
arch = x86_64
license = 3-BSD
@@ -25,6 +25,13 @@ pkgbase = python-pygmt
makedepends = python-sphinx-gallery
makedepends = python-nbsphinx
makedepends = python-numpydoc
+ makedepends = python-docformatter
+ makedepends = python-black
+ makedepends = python-blackdoc
+ makedepends = dvc
+ makedepends = python-isort
+ makedepends = python-myst-parser
+ makedepends = python-sphinx-copybutton
depends = python-numpy
depends = python-pandas
depends = python-xarray
diff --git a/PKGBUILD b/PKGBUILD
index 1f01d673ed7e..a0968815709f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkg=pygmt
pkgbase=python-${_pkg}
pkgname=("python-${_pkg}")
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
@@ -15,7 +15,9 @@ makedepends=('python-pip' 'cython' 'python-setuptools'
'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
'python-black' 'python-pylint' 'flake8' 'python-sphinx'
'python-sphinx_rtd_theme' 'python-sphinx-gallery'
- 'python-nbsphinx' 'python-numpydoc')
+ 'python-nbsphinx' 'python-numpydoc' 'python-docformatter'
+ 'python-black' 'python-blackdoc' 'dvc' 'python-isort'
+ 'python-myst-parser' 'python-sphinx-copybutton' )
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/v${pkgver}.tar.gz")
sha256sums=('65344f1316587896b17708e1a064a0c6976db40ed7b3394e4a35500cd8ae7ea8')