summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsean09212021-03-14 16:21:06 +0800
committersean09212021-03-14 16:21:06 +0800
commitd33572a2fe843fb8c24f0f9d9c326b45179b0bee (patch)
treebbd35cdd0f130a94a13315643d0aff9cd89a84df
parente6f393324adb90b2d86a83b7b64802a2d27a53b4 (diff)
downloadaur-d33572a2fe843fb8c24f0f9d9c326b45179b0bee.tar.gz
add python-pip as make dependencies
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff2b8e58c828..2002b7765c77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-pygmt
pkgdesc = Python interface to the Generic Mapping Tools C library
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.pygmt.org
arch = x86_64
license = 3-BSD
+ makedepends = python-pip
makedepends = cython
makedepends = python-setuptools
makedepends = gmt-coast
diff --git a/PKGBUILD b/PKGBUILD
index 02e570f1672e..742257bf630e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ _pkg=pygmt
pkgbase=python-${_pkg}
pkgname=("python-${_pkg}")
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt6>=6.1.1')
-makedepends=('cython' 'python-setuptools'
+makedepends=('python-pip' 'cython' 'python-setuptools'
'gmt-coast' 'gmt-dcw' 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
'python-black' 'python-pylint' 'flake8' 'python-sphinx'