summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsean09212019-04-23 23:52:33 +0800
committersean09212019-04-23 23:52:33 +0800
commitdfba37b8aa47da1ef78e0189b1ea39ba9bd2ad75 (patch)
tree1b724792ba699847660d1b082e475db226291c42
parentcb3028a302716e5294eb47950003368c4e5af9aa (diff)
downloadaur-dfba37b8aa47da1ef78e0189b1ea39ba9bd2ad75.tar.gz
move test depends to check() part
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a740ae9bc179..747651648646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,9 @@ pkgdesc="Python interface to the Generic Mapping Tools C library"
arch=('x86_64')
url="https://www.pygmt.org"
license=('3-BSD')
-#numpy, pandas, xarray, netCDF4, packaging
-makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw')
-#makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw'
-# 'ipython' 'python-matplotlib' 'jupyter' 'python-pytest' 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage' 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
-# 'python-sphinx_rtd_theme' 'python-sphinx-gallery' 'python-nbsphinx' 'python-numpydoc')
+makedepends=('cython' 'python-setuptools' 'python-numpy' 'python-pandas'
+ 'python-xarray' 'python-netcdf4' 'python-packaging'
+ 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw')
source=("https://github.com/GenericMappingTools/${_pkg,,}/archive/${pkghashver}.tar.gz")
sha256sums=('d2acb07c2d3ab5eb2ed16de99101057c45196c9d208e91884c8d5f42d2d10972')
@@ -24,13 +22,17 @@ build() {
}
#check() {
+# depends=('ipython' 'python-matplotlib' 'jupyter' 'python-pytest'
+# 'python-pytest-cov' 'python-pytest-mpl' 'python-coverage'
+# 'python-black' 'python-pylint' 'flake8' 'python-sphinx'
+# 'python-sphinx_rtd_theme' 'python-sphinx-gallery'
+# 'python-nbsphinx' 'python-numpydoc')
# cd ${_pkg}-${pkghashver}
# PYTHONPATH="../../build/lib" python -c 'import pygmt;pygmt.test()'
#}
package() {
depends=('python-numpy' 'python-pandas' 'python-xarray' 'python-netcdf4' 'python-packaging' 'gmt>=6.0.0' 'gmt-coast' 'gmt-dcw')
-
cd ${_pkg}-${pkghashver}
USE_NCCONFIG=1 python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=2
}