summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreddie bertot2017-02-16 15:26:42 -0800
committereddie bertot2017-02-16 15:26:42 -0800
commitbe5fdbacf14b5c7ad98854b0b5b6e78ec72336c3 (patch)
treef465d2a9ef4afc4ce31f04228449d58df1e637d5
parent69776e8c070c00a52c15cfe9182e235ffabd0b1c (diff)
downloadaur-be5fdbacf14b5c7ad98854b0b5b6e78ec72336c3.tar.gz
use eccodes instead of grib_api, tracking python2 version
-rwxr-xr-xPKGBUILD17
-rw-r--r--setup.cfg35
2 files changed, 44 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 867fd62c5024..7074a1b19688 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Maintainer : Liviu-Cristian Mirea-Ghiban <liviu.mirea@wecodepixels.com>
pkgname=python-pygrib
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python module for reading and writing GRIB (editions 1 and 2) files."
arch=('i686' 'x86_64')
url="https://github.com/jswhit/pygrib"
license=('MIT')
-depends=('python-pyproj' 'jasper' 'python-numpy' 'grib_api')
-source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz)
-md5sums=('e9ae04cb987992691b388b16be53214a')
+depends=('python-pyproj' 'jasper' 'python-numpy' 'eccodes')
+source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz setup.cfg)
+md5sums=('e9ae04cb987992691b388b16be53214a'
+ 'd5a6f196213d2a53c280c7be1cb1bb03')
build() {
cd "${srcdir}/pygrib-${pkgver}"
@@ -19,15 +20,15 @@ build() {
export ZLIB_DIR=/usr
export OPENJPEG_DIR=/usr
export GRIBAPI_DIR=/usr
-
+ cp ${srcdir}/setup.cfg .
+ sed -i 's/image.inmem_.*=.*1;//' g2clib_src/enc_jpeg2000.c
python setup.py build
}
package() {
cd "${srcdir}/pygrib-${pkgver}"
-
- python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
-
+ python setup.py install --prefix=/usr \
+ --root="${pkgdir}" --skip-build --optimize=1
install -dm755 "${pkgdir}"/usr/share/licenses/${pkgname}
install -m644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/
rm -fr ${pkgdir}/usr/bin
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 000000000000..843aa21353bd
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,35 @@
+# Rename this file to setup.cfg to set pygrib's
+# build options.
+# Follow instructions below for editing.
+[directories]
+# uncomment and set to grib_api install location.
+# Include files should be located in grib_api_dir/include and
+# the library should be located in grib_api_dir/lib.
+# If the libraries and include files are installed in separate locations,
+# use grib_api_libdir and grib_api_incdir to specify the locations
+# separately.
+#grib_api_dir = /usr/local
+# if grib_api was built with jasper support for JPEG200,
+# uncomment and set to jasper lib install location.
+# If the libraries and include files are installed in separate locations,
+# use jasper_libdir and jasper_incdir.
+#jasper_dir = /usr/local
+# if grib_api was built with openjpeg support for JPEG200,
+# uncomment and set to openjpeg lib install location.
+# If the libraries and include files are installed in separate locations,
+# use openjpeg_libdir and openjpeg_incdir.
+#openjpeg_dir = /usr/local
+# if grib_api was built with png support,
+# uncomment and set to png lib install location.
+# If the libraries and include files are installed in separate locations,
+# use png_libdir and png_incdir.
+#png_dir = /usr
+# if grib_api was built with png support,
+# uncomment and set to zlib install location.
+#zlib_dir = /usr
+# install man pages for command line utilities here
+#man_dir = /usr/local/man
+[files]
+# uncomment and set to grib_api library name.
+# If you are using GRIB-API with MSVS, library name might be 'grib_api_lib'.
+grib_api_libname = eccodes