summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiviu Cristian Mirea Ghiban2015-11-06 20:29:08 +0200
committerLiviu Cristian Mirea Ghiban2015-11-06 20:29:08 +0200
commitdbb91c580658d1d9170837a6c3b78b3059c18fb6 (patch)
tree0eb5a06eb2f6b889808adfd1ca235da48d38b03f
downloadaur-dbb91c580658d1d9170837a6c3b78b3059c18fb6.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cebe5215e36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pygrib
+ pkgdesc = Python module for reading and writing GRIB (editions 1 and 2) files.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/jswhit/pygrib
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python-pyproj
+ depends = jasper
+ depends = python-numpy
+ depends = grib_api
+ source = https://pypi.python.org/packages/source/p/pygrib/pygrib-2.0.0.tar.gz
+ md5sums = 0b1c150216af0b2afd7281fe2cd35483
+
+pkgname = python-pygrib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b4b96e4dec5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>, Graziano Giuliani <graziano.giuliani@gmail.com>
+# Maintainer : Liviu-Cristian Mirea-Ghiban <liviu.mirea@wecodepixels.com>
+pkgname=python-pygrib
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Python module for reading and writing GRIB (editions 1 and 2) files."
+arch=('i686' 'x86_64')
+url="https://github.com/jswhit/pygrib"
+license=('MIT')
+depends=('python-pyproj' 'jasper' 'python-numpy' 'grib_api')
+source=(https://pypi.python.org/packages/source/p/pygrib/pygrib-${pkgver}.tar.gz)
+md5sums=('0b1c150216af0b2afd7281fe2cd35483')
+
+build() {
+ cd "${srcdir}/pygrib-${pkgver}"
+
+ export JASPER_DIR=/usr
+ export PNG_DIR=/usr
+ export ZLIB_DIR=/usr
+ export OPENJPEG_DIR=/usr
+ export GRIBAPI_DIR=/usr
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/pygrib-${pkgver}"
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
+
+ install -dm755 "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -m644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/
+ rm -fr ${pkgdir}/usr/bin
+}