summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichaël Defferrard2018-10-09 17:08:41 +0200
committerMichaël Defferrard2018-10-09 17:08:41 +0200
commit72d8a5d37f1d777f13a8b00f91ae3a8ede5a68e4 (patch)
treea6bbefd0afb4849d4c7ca39b77a2465273848910
downloadaur-python-pygsp.tar.gz
PyGSP v0.5.1 (first release to Arch)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ef8d901e488
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pygsp
+ pkgdesc = Graph Signal Processing in Python
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/epfl-lts2/pygsp
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ optdepends = python-matplotlib: plot graphs, signals, and filters
+ optdepends = python-pyqtgraph: interactive graph visualization
+ optdepends = python-opengl: interactive graph visualization in 3d
+ optdepends = python-scikit-image: construct patch graphs from images
+ source = https://files.pythonhosted.org/packages/source/p/pygsp/PyGSP-0.5.1.tar.gz
+ sha256sums = 4874ad88793d622d4f578b40c6617a99b1f02bc6c6c4077f0e48cd71c7275800
+
+pkgname = python-pygsp
+ depends = python-numpy
+ depends = python-scipy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66c3f265898c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Michaël Defferrard <m.deff@hotmail.com>
+
+pkgname=python-pygsp
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="Graph Signal Processing in Python"
+arch=('any')
+url="https://github.com/epfl-lts2/pygsp"
+license=('MIT')
+optdepends=('python-matplotlib: plot graphs, signals, and filters'
+ 'python-pyqtgraph: interactive graph visualization'
+ 'python-opengl: interactive graph visualization in 3d'
+ 'python-scikit-image: construct patch graphs from images')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/p/pygsp/PyGSP-${pkgver}.tar.gz")
+sha256sums=('4874ad88793d622d4f578b40c6617a99b1f02bc6c6c4077f0e48cd71c7275800')
+
+package() {
+ depends=('python-numpy' 'python-scipy')
+ cd "PyGSP-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}