summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-04-29 11:47:08 +0200
committerCarl Smedstad2023-04-29 11:47:08 +0200
commitfebf321a9e6178294ae2b6cdc571e70fed50bd57 (patch)
treeac67ed88505c59d3e6e754a135cb193810cbc792
parent51d75ea3fd035896c2e53bac5b1df66ae0e4516b (diff)
downloadaur-febf321a9e6178294ae2b6cdc571e70fed50bd57.tar.gz
Publish version 0.18.1-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7b9b70d2ebc..e58098e38ca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyhanko
pkgdesc = Tools for stamping and signing PDF files
- pkgver = 0.17.2
- pkgrel = 3
+ pkgver = 0.18.1
+ pkgrel = 1
url = https://github.com/MatthiasValvekens/pyHanko
arch = any
license = MIT
@@ -21,7 +21,6 @@ pkgbase = python-pyhanko
depends = python-pillow
depends = python-pyhanko-certvalidator
depends = python-python-pkcs11
- depends = python-pytz
depends = python-pyyaml
depends = python-qrcode
depends = python-tzlocal
@@ -29,7 +28,7 @@ pkgbase = python-pyhanko
optdepends = python-fonttools: to use OpenType fonts
optdepends = python-defusedxml: to use XMP
optdepends = python-barcode: for image support
- source = python-pyhanko-0.17.2.tar.gz::https://github.com/MatthiasValvekens/pyHanko/archive/refs/tags/0.17.2.tar.gz
- sha256sums = c1733e3375dc425e585d76f0db7f101d64b944474a4e71b16f5692e2e19b4cc0
+ source = python-pyhanko-0.18.1.tar.gz::https://github.com/MatthiasValvekens/pyHanko/archive/refs/tags/v0.18.1.tar.gz
+ sha256sums = 906ce67c1ab71ec67f2ab1412298575ba0f2acadb2fe846eb87b13529ac53e8c
pkgname = python-pyhanko
diff --git a/PKGBUILD b/PKGBUILD
index ee38f38a1d6c..ef7bb59945b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=python-pyhanko
_name=pyHanko
-pkgver=0.17.2
-pkgrel=3
+pkgver=0.18.1
+pkgrel=1
pkgdesc="Tools for stamping and signing PDF files"
url="https://github.com/MatthiasValvekens/pyHanko"
license=(MIT)
@@ -28,7 +28,6 @@ depends=(
python-pillow
python-pyhanko-certvalidator
python-python-pkcs11
- python-pytz
python-pyyaml
python-qrcode
python-tzlocal
@@ -39,33 +38,28 @@ optdepends=(
'python-defusedxml: to use XMP'
'python-barcode: for image support'
)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('c1733e3375dc425e585d76f0db7f101d64b944474a4e71b16f5692e2e19b4cc0')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('906ce67c1ab71ec67f2ab1412298575ba0f2acadb2fe846eb87b13529ac53e8c')
_archive="$_name-$pkgver"
build() {
cd "$_archive"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd "$_archive"
python -m pytest \
- --ignore pyhanko_tests/test_csc.py \
- -k "\
- not test_ts_fetch_aiohttp \
- and not test_ac_attr_validation_holder_mismatch \
- "
+ --ignore pyhanko_tests/test_csc.py
}
package() {
cd "$_archive"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}