summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2022-10-30 05:43:23 +0100
committerMichał Wojdyła2022-10-30 05:43:23 +0100
commit45b0786824ca3cf2eaae5b47dd53418a256ec22e (patch)
treefe51bf7799413f0f47c22c99b800493832656d12
parentfb9a8a524fd03ec0e5a75161eb67d57f58db288c (diff)
downloadaur-45b0786824ca3cf2eaae5b47dd53418a256ec22e.tar.gz
update to 0.19.6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--digicert-ecc-p384-root-g5-revoked-chain-demos-digicert-com.crtbin1739 -> 0 bytes
-rw-r--r--revocation-test.patch45
4 files changed, 8 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2705a6e35a70..4cb12bddb2da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyhanko-certvalidator
pkgdesc = Validates X.509 certificates and paths
- pkgver = 0.19.5
- pkgrel = 3
+ pkgver = 0.19.6
+ pkgrel = 1
url = https://github.com/MatthiasValvekens/certvalidator
arch = any
license = MIT
@@ -13,11 +13,7 @@ pkgbase = python-pyhanko-certvalidator
depends = python-oscrypto
depends = python-cryptography
depends = python-uritools
- source = pyhanko-certvalidator-0.19.5.tar.gz::https://github.com/MatthiasValvekens/certvalidator/archive/refs/tags/0.19.5.tar.gz
- source = revocation-test.patch
- source = digicert-ecc-p384-root-g5-revoked-chain-demos-digicert-com.crt
- sha256sums = 2b3eabe4383340f8939eb559e7accfcf68e79a609bbd05ece3a7e959af1fcf4e
- sha256sums = 73f997673be82a9d75f9a127e5303a05cf539e0955f7730e5a1f73596701da8c
- sha256sums = 16ce93e1e0126da8be9b77e70446ed5e3faa8b7c3ebc514b512919633b2b5ca6
+ source = pyhanko-certvalidator-0.19.6.tar.gz::https://github.com/MatthiasValvekens/certvalidator/archive/refs/tags/0.19.6.tar.gz
+ sha256sums = b34f3ad5d335763171444135ecb86cc92dc264722f4645c224e63853f4b66a0c
pkgname = python-pyhanko-certvalidator
diff --git a/PKGBUILD b/PKGBUILD
index 8bb8a7732133..e5fe1ebe678b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
_name=pyhanko-certvalidator
pkgname='python-pyhanko-certvalidator'
-pkgver=0.19.5
-pkgrel=3
+pkgver=0.19.6
+pkgrel=1
pkgdesc="Validates X.509 certificates and paths"
url="https://github.com/MatthiasValvekens/certvalidator"
license=('MIT')
@@ -11,19 +11,8 @@ depends=('python-requests' 'python-asn1crypto' 'python-oscrypto' 'python-cryptog
'python-uritools')
makedepends=('python-setuptools')
checkdepends=('python-oscrypto-tests' 'python-aiohttp')
-source=("${_name}-${pkgver}.tar.gz::https://github.com/MatthiasValvekens/certvalidator/archive/refs/tags/$pkgver.tar.gz"
- "revocation-test.patch"
- "digicert-ecc-p384-root-g5-revoked-chain-demos-digicert-com.crt")
-sha256sums=('2b3eabe4383340f8939eb559e7accfcf68e79a609bbd05ece3a7e959af1fcf4e'
- '73f997673be82a9d75f9a127e5303a05cf539e0955f7730e5a1f73596701da8c'
- '16ce93e1e0126da8be9b77e70446ed5e3faa8b7c3ebc514b512919633b2b5ca6')
-
-prepare() {
- cd certvalidator-${pkgver}
- # https://github.com/MatthiasValvekens/certvalidator/commit/54e09a087bc6a46c67205f2596d5a3cb7d4e61c8
- mv ../digicert-ecc-p384-root-g5-revoked-chain-demos-digicert-com.crt tests/fixtures
- patch -Np1 -i ../revocation-test.patch
-}
+source=("${_name}-${pkgver}.tar.gz::https://github.com/MatthiasValvekens/certvalidator/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('b34f3ad5d335763171444135ecb86cc92dc264722f4645c224e63853f4b66a0c')
build() {
cd certvalidator-${pkgver}
diff --git a/digicert-ecc-p384-root-g5-revoked-chain-demos-digicert-com.crt b/digicert-ecc-p384-root-g5-revoked-chain-demos-digicert-com.crt
deleted file mode 100644
index 2ce21adc7091..000000000000
--- a/digicert-ecc-p384-root-g5-revoked-chain-demos-digicert-com.crt
+++ /dev/null
Binary files differ
diff --git a/revocation-test.patch b/revocation-test.patch
deleted file mode 100644
index 30755dd0c822..000000000000
--- a/revocation-test.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/tests/test_validate.py
-+++ b/tests/test_validate.py
-@@ -171,7 +171,8 @@ def test_revocation_mode_hard(self):
-
- expected = (
- '(CRL|OCSP response) indicates the end-entity certificate was '
-- 'revoked at 22:42:35 on 2021-08-17, due to an unspecified reason'
-+ 'revoked at \\d\\d:\\d\\d:\\d\\d on \\d\\d\\d\\d-\\d\\d-\\d\\d'
-+ ', due to an unspecified reason'
- )
- with self.assertRaisesRegex(RevokedError, expected):
- validate_path(context, path)
-@@ -201,8 +202,8 @@ async def test_revocation_mode_hard_async(self):
-
- expected = (
- '(CRL|OCSP response) indicates the end-entity certificate was '
-- 'revoked at 22:42:35 on 2021-08-17, due to an unspecified '
-- 'reason'
-+ 'revoked at \\d\\d:\\d\\d:\\d\\d on \\d\\d\\d\\d-\\d\\d-\\d\\d'
-+ ', due to an unspecified reason'
- )
- with self.assertRaisesRegex(RevokedError, expected):
- await async_validate_path(context, path)
-@@ -229,8 +230,8 @@ async def test_revocation_mode_hard_aiohttp_autofetch(self):
-
- expected = (
- '(CRL|OCSP response) indicates the end-entity certificate was '
-- 'revoked at 22:42:35 on 2021-08-17, due to an unspecified '
-- 'reason'
-+ 'revoked at \\d\\d:\\d\\d:\\d\\d on \\d\\d\\d\\d-\\d\\d-\\d\\d'
-+ ', due to an unspecified reason'
- )
- with self.assertRaisesRegex(RevokedError, expected):
- await async_validate_path(context, path)
-@@ -257,8 +258,8 @@ async def test_revocation_mode_hard_requests_autofetch(self):
-
- expected = (
- '(CRL|OCSP response) indicates the end-entity certificate was '
-- 'revoked at 22:42:35 on 2021-08-17, due to an unspecified '
-- 'reason'
-+ 'revoked at \\d\\d:\\d\\d:\\d\\d on \\d\\d\\d\\d-\\d\\d-\\d\\d'
-+ ', due to an unspecified reason'
- )
- with self.assertRaisesRegex(RevokedError, expected):
- await async_validate_path(context, path)