summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 19:34:35 +0000
committerAntonio Rojas2020-05-01 19:34:35 +0000
commit8a8c42bca6ce65b92a59f8b88b269837f5293591 (patch)
tree8acc9ed1b5b3d29fa32ef6a7ed5cedf704878b9c
parent63eb964619ea3a60498f9abf02e130b5a84a8f96 (diff)
downloadaur-python-pyinsane.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 31 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 605dbb88a46b..dba8c0d52a7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
-# Generated by mksrcinfo v8
-# Wed Dec 23 13:18:03 UTC 2015
pkgbase = python-pyinsane
- pkgdesc = Python implementation of the Sane API (using ctypes) and abstration layer
- pkgver = 1.3.8
- pkgrel = 1
- url = https://github.com/jflesch/pyinsane
+ pkgdesc = Python library to access and use image scanners
+ pkgver = 2.0.13
+ pkgrel = 2
+ url = https://gitlab.gnome.org/World/OpenPaperwork/pyinsane
arch = any
license = GPL3
- makedepends = python
+ makedepends = git
makedepends = python-setuptools
- depends = libksane
- provides = python-pyinsane
- conflicts = python-pyinsane
- source = https://github.com/jflesch/pyinsane/archive/v1.3.8.zip
- md5sums = ac7a0b2ebc14800dc82a88bc35314069
+ depends = python-pillow
+ depends = sane
+ source = git+https://gitlab.gnome.org/World/OpenPaperwork/pyinsane.git#commit=3e509e6bdd2c07ac715cfc27946f86123744a46e
+ sha256sums = SKIP
pkgname = python-pyinsane
diff --git a/PKGBUILD b/PKGBUILD
index 18b949ef851c..95c048190dcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
-# Maintainer: Francois Boulogne <fboulogne@april.org>
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+_pkgname=pyinsane
pkgname=python-pyinsane
-pkgver=1.3.8
-pkgrel=1
-pkgdesc='Python implementation of the Sane API (using ctypes) and abstration layer'
-arch=('any')
-url='https://github.com/jflesch/pyinsane'
-license=('GPL3')
-depends=('libksane')
-optdepends=('python-pillow')
-provides=('python-pyinsane')
-conflicts=('python-pyinsane')
-makedepends=('python' 'python-setuptools')
-source=("https://github.com/jflesch/pyinsane/archive/v${pkgver}.zip")
+pkgver=2.0.13
+pkgrel=2
+pkgdesc="Python library to access and use image scanners"
+arch=(any)
+url="https://gitlab.gnome.org/World/OpenPaperwork/pyinsane"
+license=(GPL3)
+depends=(python-pillow sane)
+makedepends=(git python-setuptools)
+_commit=3e509e6bdd2c07ac715cfc27946f86123744a46e # tags/2.0.13^0
+source=("git+https://gitlab.gnome.org/World/OpenPaperwork/pyinsane.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
build() {
- cd "pyinsane-${pkgver}"
- python setup.py build
+ cd $_pkgname
+ make
}
package() {
- cd "pyinsane-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd $_pkgname
+ python3 setup.py install --root="$pkgdir" --optimize=1
}
-# vim:ts=2:sw=2:et:
-md5sums=('ac7a0b2ebc14800dc82a88bc35314069')