summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-04-06 09:44:05 +0200
committerPhilipp A2017-04-06 09:44:05 +0200
commit696fcfa71d3ef1280d160b4a796635812ded9783 (patch)
treefce6a2d597b7bc84d121442fe917a719018392e0
downloadaur-696fcfa71d3ef1280d160b4a796635812ded9783.tar.gz
v1.1.1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d7c86c1a31c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pyjnius
+ pkgdesc = Python module to access Java class as Python class, using JNI.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/kivy/pyjnius
+ arch = any
+ license = LGPL3
+ makedepends = cython
+ depends = java-environment
+ depends = python
+ source = pyjnius-1.1.1.tar.gz::https://github.com/kivy/pyjnius/tarball/1.1.1
+ md5sums = 2d457e4761b27e6760cf54efb6201f17
+
+pkgname = python-pyjnius
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..24f2ec57e666
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..884fdfd2a13c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+_name=pyjnius
+pkgname=python-pyjnius
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Python module to access Java class as Python class, using JNI.'
+arch=(any)
+url="https://github.com/kivy/$_name"
+license=(LGPL3)
+depends=(java-environment python)
+makedepends=(cython)
+source=("$_name-$pkgver.tar.gz::https://github.com/kivy/$_name/tarball/$pkgver")
+md5sums=(2d457e4761b27e6760cf54efb6201f17)
+
+build() {
+ cd "kivy-$_name-"*
+
+ python setup.py build_ext --inplace -f
+ python setup.py build
+}
+
+package() {
+ export PYTHONPATH="$pkgdir/usr/lib/$(readlink /usr/bin/python3)/site-packages"
+ mkdir -p "$PYTHONPATH"
+
+ cd "$srcdir/kivy-$_name-"*
+ python setup.py install --prefix="$pkgdir/usr" --optimize=1
+}