summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-04-25 12:40:07 -0400
committerJames An2016-04-25 12:40:07 -0400
commitdf11df33b730ee9a168e36901a8155dd739df2c3 (patch)
tree705d918619f0cf9c30101a4769db669822f6ff2c
downloadaur-df11df33b730ee9a168e36901a8155dd739df2c3.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rwxr-xr-x.gitignore27
-rw-r--r--PKGBUILD23
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..534697fe1647
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyjslint
+ pkgdesc = JSLint wrapper for Python
+ pkgver = 0.3.4
+ pkgrel = 2
+ url = https://pypi.python.org/pypi/pyjslint/0.3.4
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = nodejs
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/pyjslint/pyjslint-0.3.4.tar.gz
+ md5sums = cb8a0aa4edf470f04cd058e33994997b
+
+pkgname = python-pyjslint
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f38dd6395e44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=python-pyjslint
+_pkgname=pyjslint
+pkgver=0.3.4
+pkgrel=2
+pkgdesc='JSLint wrapper for Python'
+arch=('any')
+url="https://pypi.python.org/pypi/${_pkgname}/${pkgver}"
+license=('BSD')
+depends=('nodejs' 'python')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+install=
+source=("https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('cb8a0aa4edf470f04cd058e33994997b')
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}