summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Mischke2023-07-31 08:40:25 +0200
committerPatrick Mischke2023-07-31 08:40:25 +0200
commit9ed30d09a5d1707968ac91be71e3c87caf251b46 (patch)
tree62262459a721e3a4ba32462ef2bb33511414de9d
parent9c2603a1dffd0b81f45707ba8a647b223b347277 (diff)
downloadaur-9ed30d09a5d1707968ac91be71e3c87caf251b46.tar.gz
Bump version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86bce25f5e2d..23516bb67fb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyjson5
pkgdesc = A JSON5 serializer and parser library for Python 3 written in Cython.
- pkgver = 1.6.3
+ pkgver = 1.6.4
pkgrel = 1
url = https://github.com/Kijewski/pyjson5
arch = any
@@ -15,7 +15,9 @@ pkgbase = python-pyjson5
makedepends = python-wheel
depends = cython
depends = python-more-itertools
- source = https://files.pythonhosted.org/packages/source/p/pyjson5/pyjson5-1.6.3.tar.gz
- sha256sums = 225afea5f72f64c594f4e379788f25629ed2543bf9659786e80d19c942da0960
+ source = https://github.com/Kijewski/pyjson5/archive/refs/tags/v1.6.4.tar.gz
+ source = https://github.com/lemire/fast_double_parser/archive/refs/tags/v0.7.0.tar.gz
+ sha256sums = 7d853614607ee5fc6ae8a7dd5cb68644db7fb95422fd320fc8238ba7674bb1b5
+ sha256sums = eb80a1d9c406bbe8cb22fffd3c007651f716abd03225009302d8aba8e9c4df77
pkgname = python-pyjson5
diff --git a/PKGBUILD b/PKGBUILD
index ef5f1c564552..66d84e0fe4c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='python-pyjson5'
_name='pyjson5'
-pkgver=1.6.3
+pkgver=1.6.4
pkgrel=1
pkgdesc="A JSON5 serializer and parser library for Python 3 written in Cython."
url="https://github.com/Kijewski/pyjson5"
@@ -10,10 +10,11 @@ depends=('cython' 'python-more-itertools')
makedepends=('python-build' 'python-colorama' 'python-docutils' 'python-setuptools' 'python-sphinx' 'python-sphinx-autodoc-typehints' 'python-sphinx_rtd_theme' 'python-wheel')
license=('Apache')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('225afea5f72f64c594f4e379788f25629ed2543bf9659786e80d19c942da0960')
+source=("https://github.com/Kijewski/pyjson5/archive/refs/tags/v$pkgver.tar.gz" "https://github.com/lemire/fast_double_parser/archive/refs/tags/v0.7.0.tar.gz")
+sha256sums=('7d853614607ee5fc6ae8a7dd5cb68644db7fb95422fd320fc8238ba7674bb1b5' 'eb80a1d9c406bbe8cb22fffd3c007651f716abd03225009302d8aba8e9c4df77')
build() {
+ cp -r -T fast_double_parser-0.7.0 "$_name-$pkgver/third-party/fast_double_parser"
cd "$_name-$pkgver"
python setup.py build
}