summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpacosalces2023-06-10 20:01:27 -0700
committerpacosalces2023-06-10 20:01:27 -0700
commit188db80ea44ea71938d94d8f0f84d45a6d4a0051 (patch)
tree8a5b13d7659efffa7e5982cec7fbe6439be38fb6
parent0073f34900637d2eb54ded6b6c3eb31ffe5e6aa5 (diff)
downloadaur-188db80ea44ea71938d94d8f0f84d45a6d4a0051.tar.gz
change source, update PKGBUILD and SRCINFO, and bump to version 1.2.94
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1db251010f1c..f75d3c66495c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = python-pykat
pkgdesc = Python interface and tools for FINESSE
- pkgver = 1.2.81
+ pkgver = 1.2.94
pkgrel = 1
- url = https://pypi.org/project/PyKat/
+ url = https://www.gwoptics.org/pykat/
arch = any
license = GPL2
- makedepends = python-setuptools
depends = finesse
- source = https://files.pythonhosted.org/packages/source/P/PyKat/PyKat-1.2.81.tar.gz
- sha256sums = f2dc912aee7ae7b1f3a193fe1dfd155c6ff8527b0e7e3a1d649d090c63a7472c
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-six
+ depends = python-h5py-git
+ depends = python-pandas
+ depends = python-matplotlib
+ depends = python-tabulate
+ depends = python-click
+ source = git+https://git.ligo.org/finesse/pykat
+ sha256sums = SKIP
pkgname = python-pykat
diff --git a/PKGBUILD b/PKGBUILD
index 9b9aa788519d..5702e348601c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Francisco Salces Carcoba <pacosalces@gmail.com>
# Contributor: Christopher Billington <chrisjbillington@gmail.com>
pkgname=python-pykat
-_name=PyKat
-pkgver=1.2.81
+_name=pykat
+pkgver=1.2.94
pkgrel=1
pkgdesc="Python interface and tools for FINESSE"
license=("GPL2")
-url="https://pypi.org/project/PyKat/"
-makedepends=('python-setuptools')
-depends=('finesse')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('6721071a852ac96603cb6afd4c79e25a1993b022580ff41dcb92c0b2eacf9f70')
+url="https://www.gwoptics.org/pykat/"
+depends=('finesse' 'python-numpy' 'python-scipy' 'python-six' 'python-h5py-git' 'python-pandas' 'python-matplotlib' 'python-tabulate' 'python-click')
+source=("git+https://git.ligo.org/finesse/$_name")
+sha256sums=('SKIP')
arch=('any')
build() {
- cd $srcdir/${_name}-$pkgver
+ cd $srcdir/${_name}
python setup.py build
}
package() {
- cd $srcdir/${_name}-$pkgver
+ cd $srcdir/${_name}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
+