summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinicius Correa2018-05-31 11:43:22 -0300
committerVinicius Correa2018-05-31 11:43:22 -0300
commite6632be28446bc88013e6f287871f8e4579985d7 (patch)
tree82611c1e3125caf5cca4cc9f8225a2c5335062bf
downloadaur-e6632be28446bc88013e6f287871f8e4579985d7.tar.gz
first
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48742a823906
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pykcs11
+ pkgdesc = PKCS#11 wrapper for Python.
+ pkgver = 1.4.4
+ pkgrel = 1
+ url = https://github.com/LudovicRousseau/PyKCS11
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = swig
+ source = https://github.com/LudovicRousseau/PyKCS11/archive/1.4.4.tar.gz
+ md5sums = dc5fdeeb92eeee7125eb418a523c59f8
+
+pkgname = python-pykcs11
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a5754f739e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Vinicius Correa <vinicius dot correa at zoho dot com>
+_pkgname=PyKCS11
+pkgname=python-pykcs11
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="PKCS#11 wrapper for Python."
+arch=('any')
+url="https://github.com/LudovicRousseau/${_pkgname}"
+license=('GPL')
+depends=('python' 'swig')
+makedepends=('git')
+optdepends=()
+conflicts=()
+source=("https://github.com/LudovicRousseau/${_pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('dc5fdeeb92eeee7125eb418a523c59f8')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}