summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2022-03-30 13:43:34 -0400
committerDylan Delgado2022-03-30 13:43:34 -0400
commit0935dd880715e50655d2a458508fa3e83860e439 (patch)
tree2da37318d4bc6caede34dc21cca45c1b40d86108
parent54ac15eee08cff2ac64773aa94a4369b8c428bcf (diff)
downloadaur-0935dd880715e50655d2a458508fa3e83860e439.tar.gz
Update to 2.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ba936b0b26d..1877da6eb5c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pykeops
pkgdesc = Python bindings for the cpp/cuda library KeOps.
- pkgver = 1.5
+ pkgver = 2.0
pkgrel = 1
url = http://www.kernel-operations.io/keops/index.html
arch = x86_64
@@ -12,8 +12,7 @@ pkgbase = python-pykeops
depends = cmake
depends = cuda
depends = python-pytorch>=1.5.0
- source = https://files.pythonhosted.org/packages/8a/93/7ebaa0f2dc54965c510a7b9075fc8a6a51a5e1413b4bf6a97a2ceb9a572f/pykeops-1.5.tar.gz
- sha256sums = e7c846bb1fe48f89c4a9660b27a1216dd3478dc1399144e827d9223aa031acd9
+ source = https://files.pythonhosted.org/packages/dd/45/f15412a8bc3f9cf8b6def596e53dba5a39a3229e4956968fdf582902d26c/pykeops-2.0.tar.gz
+ sha256sums = 2766a607c2df45fdebb717153fd8efa4296251d081abdd4fa3fabe6708d5925b
pkgname = python-pykeops
-
diff --git a/PKGBUILD b/PKGBUILD
index f2b9cd9035bc..d54b1c8e60ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dylan14 <dylan1496 at live dot com>
pkgname=python-pykeops
-pkgver=1.5
+pkgver=2.0
pkgrel=1
pkgdesc="Python bindings for the cpp/cuda library KeOps."
arch=('x86_64')
@@ -9,8 +9,8 @@ url="http://www.kernel-operations.io/keops/index.html"
license=('MIT')
depends=('python' 'python-numpy' 'gcc>=7.0.0' 'cmake' 'cuda' 'python-pytorch>=1.5.0')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/8a/93/7ebaa0f2dc54965c510a7b9075fc8a6a51a5e1413b4bf6a97a2ceb9a572f/pykeops-$pkgver.tar.gz")
-sha256sums=('e7c846bb1fe48f89c4a9660b27a1216dd3478dc1399144e827d9223aa031acd9')
+source=("https://files.pythonhosted.org/packages/dd/45/f15412a8bc3f9cf8b6def596e53dba5a39a3229e4956968fdf582902d26c/pykeops-$pkgver.tar.gz")
+sha256sums=('2766a607c2df45fdebb717153fd8efa4296251d081abdd4fa3fabe6708d5925b')
_pkgname=pykeops
@@ -22,4 +22,4 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="$pkgdir"/ --optimize=1
-} \ No newline at end of file
+}