summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Rooyakkers2018-02-08 19:57:15 -0500
committerLucas Rooyakkers2018-02-08 19:57:15 -0500
commitc436294a992f8d289cafe3862d9ac9b53ce6d840 (patch)
tree6f827f600de6b7d941c5cf3c246481e7198d42a0
downloadaur-c436294a992f8d289cafe3862d9ac9b53ce6d840.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD18
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83160234dcd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-pykml
+ pkgdesc = pyKML is a Python package for parsing and authoring KML documents. It is based on the lxml.objectify API (http://codespeak.net/lxml/objectify.html) which provides Pythonic access to XML documents.
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://pythonhosted.org/pykml/
+ arch = any
+ license = BSD
+ depends = python
+ source = https://pypi.python.org/packages/8f/16/276e16f024db5aca4c8891cecd56219a5a1e016fa356e858dfb04590b1d5/pykml-0.1.3.tar.gz
+ md5sums = bc5c499b4e16cf51d502f9c828284f96
+
+pkgname = python-pykml
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e5bed7bb2477
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+*.pkg.tar.xz
+src/
+*.tar.gz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3c7fe2dac4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Mainintainer : Lucas Rooyakkers <lucas.rooyakkers@queensu.ca>
+
+_pkgname=pykml
+pkgname=python-pykml
+pkgver=0.1.3
+pkgrel=1
+pkgdesc='pyKML is a Python package for parsing and authoring KML documents. It is based on the lxml.objectify API (http://codespeak.net/lxml/objectify.html) which provides Pythonic access to XML documents.'
+arch=('any')
+url="https://pythonhosted.org/pykml/"
+license=('BSD')
+depends=('python')
+source=('https://pypi.python.org/packages/8f/16/276e16f024db5aca4c8891cecd56219a5a1e016fa356e858dfb04590b1d5/pykml-0.1.3.tar.gz')
+md5sums=('bc5c499b4e16cf51d502f9c828284f96')
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir"
+}