summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2017-08-17 22:21:50 -0400
committerEric Berquist2017-08-17 22:28:07 -0400
commitd502d36c35cfc3f0c0f0ac91297cd1a3e1a07ccc (patch)
tree919a8ccc71a2182f25a3d83bea9eaf6ad153bd94
downloadaur-d502d36c35cfc3f0c0f0ac91297cd1a3e1a07ccc.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD39
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..288429f105d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Aug 18 02:27:42 UTC 2017
+pkgbase = python-pylatex-git
+ pkgdesc = A Python library for creating LaTeX files (git version)
+ pkgver = 1.2.2.r685.3642fd2
+ pkgrel = 1
+ url = https://jeltef.github.io/PyLaTeX/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ optdepends = python-numpy
+ optdepends = python-matplotlib
+ optdepends = python-quantities
+ provides = python-pylatex
+ conflicts = python-pylatex
+ source = pylatex::git+https://github.com/JelteF/PyLaTeX
+ sha256sums = SKIP
+
+pkgname = python-pylatex-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d0e3faf82f5e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# makepkg files
+pkg/
+src/
+*.xz
+
+# source files
+pylatex/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a88d780bb574
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Eric Berquist <eric dot berquist at gmail dot com>
+
+_name="pylatex"
+pkgname="python-${_name}-git"
+pkgver=1.2.2.r685.3642fd2
+pkgrel=1
+pkgdesc="A Python library for creating LaTeX files (git version)"
+arch=("any")
+url="https://jeltef.github.io/PyLaTeX/"
+license=("MIT")
+depends=("python")
+makedepends=("git")
+optdepends=("python-numpy" "python-matplotlib" "python-quantities")
+provides=("python-${_name}")
+conflicts=("python-${_name}")
+source=("${_name}::git+https://github.com/JelteF/PyLaTeX")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ _parent_ver=$(git log --tags --simplify-by-decoration --pretty="format:%d" | head -n 1 | cut -d " " -f 3 | tr -d "v,)")
+ _parent_major_ver=$(echo "${_parent_ver}" | cut -d "." -f 1)
+ _parent_minor_ver=$(echo "${_parent_ver}" | cut -d "." -f 2)
+ _parent_patch_ver=$(echo "${_parent_ver}" | cut -d "." -f 3)
+ # Don't use the patch version of the parent tag.
+ _git_patch_ver=$((_parent_patch_ver+1))
+ printf "%s.%s.%s.r%s.%s" \
+ "${_parent_major_ver}" \
+ "${_parent_minor_ver}" \
+ "${_git_patch_ver}" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}