summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPluggi2016-02-14 17:51:51 +0100
committerPluggi2016-02-14 17:51:51 +0100
commit4faebb46905a81a23cd2af64e30d880f246bafeb (patch)
tree3e8ea4d58b711511c0ed0ec0cca745e2c8c4d44e
downloadaur-4faebb46905a81a23cd2af64e30d880f246bafeb.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b51e94600d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Feb 14 16:50:55 UTC 2016
+pkgbase = python-pyldap
+ pkgdesc = Python modules for implementing LDAP clients
+ pkgver = 2.4.25
+ pkgrel = 2
+ url = https://github.com/pyldap/pyldap
+ arch = any
+ license = PSFL
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/pyldap/pyldap-2.4.25.tar.gz
+ md5sums = dbcb7849b506b58d22cb711564df58a7
+
+pkgname = python-pyldap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..191dbcb43bce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/Python_Package_Guidelines for more
+# information on Python packaging.
+
+pkgname=python-pyldap
+pkgver=2.4.25
+pkgrel=2
+pkgdesc="Python modules for implementing LDAP clients"
+_pipname=pyldap
+arch=(any)
+url="https://github.com/pyldap/pyldap"
+license=('PSFL')
+groups=()
+depends=('python')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(https://pypi.python.org/packages/source/p/${_pipname}/${_pipname}-${pkgver}.tar.gz)
+md5sums=('dbcb7849b506b58d22cb711564df58a7')
+
+package() {
+ cd "$srcdir/$_pipname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: